How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask BOBBYSS Your Own Question
BOBBYSS
BOBBYSS, Master Technician
Category: Chevy
Satisfied Customers: 17142
Experience:  ASE MASTER CERTIFIED, AA DEGREE AUTO/DIESEL TECH
1627031
Type Your Chevy Question Here...
BOBBYSS is online now
A new question is answered every 9 seconds

2002 suburban.....was running then started stalling...I have

Customer Question

Hi Dan 2002 suburban.....was running then started stalling...I have 50 psi fuel rail pressure at cranking.....I don't think it is the fuel pump...haven't checked spark yet...but I hear all kinds of things on the security system...
Submitted: 1 year ago.
Category: Chevy
Expert:  BOBBYSS replied 1 year ago.

Hello, my name is Bobby. Thanks for the question. Can you tell me if the Suburban is starting and running now?

Customer: replied 1 year ago.
no it is not
Expert:  BOBBYSS replied 1 year ago.

Thanks. So as of right now it just cranks over? Any attempt to start or just steady cranking?

Customer: replied 1 year ago.
It seems like it sometimes wants to try but mostly just cranking
Expert:  BOBBYSS replied 1 year ago.

Thanks. If the security light is on while cranking the engine then the security system is shutting the fuel injectors down. If not then it may be a failure in the ignition switch or more commonly the crank position sensor.

Customer: replied 1 year ago.
I should check for sparkIf no spark start with the ignition switch or crank position sensor?I had a weird flex fuel code but I assumed it was related to the car running rough and stalling just before it died
P0300 and P0179
Expert:  BOBBYSS replied 1 year ago.

I would check for spark first. Then if there is spark try adding some fuel directly into the engine to see if it will start. That will give us a good place to start.

Customer: replied 1 year ago.
Checked the spark on second plug on the drivers side bank...got a spark. I shot in some starting fluid in the throttle and got it to start.....at first is would start and die then after a while I could get it to idle bit the idle is rough at low rpm but smooths out at higher rpm.......My next thought was to clean the throttle body and MAP sensor.....then see how it runs.....I did add some gas from a gas can to this truck a few hours before it started acting up....maybe now I have bad gas? Or could there be an issue with the timing....Please give me the next few steps I should do.....I am trying to sell this truck by the weekend....ThnaksTed
Customer: replied 1 year ago.
I will also check all the spark plugs on each cylinder to make sure I don't have a coil problem
Customer: replied 1 year ago.
Also after I cleared all the codes I spoke of earlier after I got this running I got a P0179 error code.....flex fuel sensor.....could this be contributing to the bad idle condition?
Expert:  BOBBYSS replied 1 year ago.

Thanks Ted. If it will run with the starting fluid then it does have spark and it should have compression and timing. It sounds like either the fuel injectors are not pulsing or the crank sensor is not sending a signal and cycling the injectors. Do you have a noid light to check for injector pulse?

Customer: replied 1 year ago.
No I don't.....any other way to check them?
Expert:  BOBBYSS replied 1 year ago.

You can use a voltage meter set on a/c between the two terminals on one of the injector connectors and crank the engine to see if there is a voltage signal.

Expert:  BOBBYSS replied 1 year ago.

Does the tach show an rpm signal when cranking the engine?

Customer: replied 1 year ago.
Just to be clear I got the engine running on the gas int he tank not the starting fluid...it was idling for about 15 minutes.....real rough at first,,,,then as I could increase the gas flow with the accelerator pedal...was a little tricky to keep it running I could get 2500 rpm going just slow idle is rough
Customer: replied 1 year ago.
OK do I do this on all the injectors?
Customer: replied 1 year ago.
the tach is showing rpm ....I had the engine running at 2000 to 2500 rpm...slow idle is rough aroung 500 rpm
Expert:  BOBBYSS replied 1 year ago.

Thanks. That does clarify this. From that description and from the code you are getting you need to replace the fuel composition sensor.

Customer: replied 1 year ago.
Do you think the fuel composition sensor went bad because of any chance of bad gas? Or it just failed
Expert:  BOBBYSS replied 1 year ago.

These typically will just fail, but it can be bad gas.

Customer: replied 1 year ago.
OK I guess I should get a sensor and dump the gas.....full tank of gas....to which I topped off with some gas from a gas can....ANy idea about the price of the fuel compensation sensor
Expert:  BOBBYSS replied 1 year ago.

They are usually about $300-400.

Related Chevy Questions