How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask jazzmaster Your Own Question
jazzmaster
jazzmaster, ASE Certified Technician
Category: Chevy
Satisfied Customers: 2951
Experience:  ASE .AUTO TECH FOR THIRTY-FIVE YRS,ELCTRICAL,FUEL INJECTION ETC.
8668911
Type Your Chevy Question Here...
jazzmaster is online now
A new question is answered every 9 seconds

1995 chevy 3500 with a 7.4 it has very very weak spark it

Customer Question

1995 chevy 3500 with a 7.4
it has very very weak spark it does have a good injector pulse, The truck had a miss I pulled a plug wire to start to check the miss and the truck died and did not restart, I have replaced the distributor, coil, both with new parts still same out come, also the pcm and check the grounds and tested the grounds from the pcm the distributor, still no changes still very weak spark and no start
Submitted: 1 year ago.
Category: Chevy
Expert:  jazzmaster replied 1 year ago.

hi, let me check a few things here and I will get back to you shortly ...jazzmaster ..

Expert:  jazzmaster replied 1 year ago.

do you have good grounds from the motor to the frame/body ?

Customer: replied 1 year ago.
I have a new grounds to the body and to the frame
Customer: replied 1 year ago.
DOSE THE PCM HAVE THAT MUCH CONTROLE OF THE SPARK?
Expert:  jazzmaster replied 1 year ago.

no, the pcm is more for the injectors and idle etc .,the spark is more controlled by the dist /coil

Expert:  jazzmaster replied 1 year ago.

do you have battery voltage at the coil with the key on -pink wire

Customer: replied 1 year ago.
12 V
Expert:  jazzmaster replied 1 year ago.

do you have battery voltage on the pink wire at the dist with the key on >?

Customer: replied 1 year ago.
I do 12.50 with Key on
Customer: replied 1 year ago.
12.50 VOLTS
Expert:  jazzmaster replied 1 year ago.

are these newer spark plug wires ?

do you have hot spark from the coil to the dist cap ?

Customer: replied 1 year ago.
me spark plug wires and I just for the heck of it put up brand-new distributor and it did not make any difference either
Expert:  jazzmaster replied 1 year ago.

is it hot at the dist --coil wire or is the spark weak all around

Customer: replied 1 year ago.
There is a very very weak spark at the coil wire none that I can pick up at the plug wires at the spark plugs
Expert:  jazzmaster replied 1 year ago.

do you want to talk via the phone ,it cost a little more but we can be direct instead of back and forth -I think its around $10 ,but we can continue here anyways ..

Expert:  jazzmaster replied 1 year ago.

is the voltage pulsating a little on the pink wire at the dist when it is being cranked over .or the white wire

ANd I know you got a new dist but has the ignition module been changed ?

Customer: replied 1 year ago.
New distributor came with new module
Expert:  jazzmaster replied 1 year ago.

does your truck have a tach/rpm gauge in the dash ?

and if it does ,is it moving when you crank it over ?

and you said you changed the pcm ?

Customer: replied 1 year ago.
No tach. We put origanal p c m back in
Expert:  jazzmaster replied 1 year ago.

can you see if you have a rpm with the white wire at the coil or with a scanner ?

Customer: replied 1 year ago.
No r
Customer: replied 1 year ago.
No rpm
Customer: replied 1 year ago.
There is no external crank sensor
Customer: replied 1 year ago.
We do not
Customer: replied 1 year ago.
We do not have RPM with the scanner
Customer: replied 1 year ago.
Could Computer prom possibly be bad ?
Expert:  jazzmaster replied 1 year ago.

did you by chance check the fuses ?

if not check all of them .

I say this because there may be fuses that are blown that you didn't know about ..

at the ecm/pcm check at terminals -F15 and E 15 these should show bat voltage in the run or start position -pink wires

at -E 16 -orange wire this will be hot at all times .....

Customer: replied 1 year ago.
all three have power with key on
Expert:  jazzmaster replied 1 year ago.

you have all the grounds and hots injector pulse but weak spark from the coil and I assume the voltage isn't pulsing like it should from the coil ,this and no tach/rpm this points to the ecm or prom .

you tried another ecm ?

Customer: replied 1 year ago.
Picked a used one to day with a prom in it matching numbers. did not change any thing.....
Expert:  jazzmaster replied 1 year ago.

same number on the proms ?

Customer: replied 1 year ago.
Tried a rebuilt and a used ecm and 1 used prom would have liked a new prom but haved not found one yet.
Expert:  jazzmaster replied 1 year ago.

was the used prom the same numbers ?

Customer: replied 1 year ago.
Sorry it took so long to get back to you this morning when I got to the shop check the prom numbers the prom numbers are not the same
Expert:  jazzmaster replied 1 year ago.

yeah, that is what I thought ...

The numbers have to match I would think this is the issue .but it may be that the ecm is bad as well.if you tried the prom in a different ecm and it still had the same issue then it points to the prom ,esp. if you dont have any rpm signal ..thank you ..jazzmaster ..

Customer: replied 1 year ago.
The prom for that truck has been discontinued so I had to order a custom prom should should be coming overnight be here in the morning
Expert:  jazzmaster replied 1 year ago.

do you still have the used ecm ?

Customer: replied 1 year ago.
I have the original ECM I have a used PCM and I also have a rebuilt PCM
Expert:  jazzmaster replied 1 year ago.

good first try the original ecm ,then the rebuilt ecm.

also, disconnect the timing wire -tan/black and see if it starts or has better spark -this takes the ecm out of the starting system ...jazzmaster ..

Customer: replied 1 year ago.
New prom came did what you said between the two computers still no start or rpm signal
Customer: replied 1 year ago.
Also no better's bark virtually hardly any spark
Expert:  jazzmaster replied 1 year ago.

this does have a new dist and ignition module cap and rotor and this had weak spark even before all that ?

have you tried and disconnected the timing wire _brown and tan and seen what the spark looked like then ?

Customer: replied 1 year ago.
I disconnected the timing wire matter fact it's still disconected
Expert:  jazzmaster replied 1 year ago.

wow ,let me look further into this ,this is weird as you have the powers and grounds to the ecm .and you have 12 volts or so, on the coil ...

Customer: replied 1 year ago.
Its Perplexed everybody in my shop and in multiple shops
Expert:  jazzmaster replied 1 year ago.

when you are cranking the motor over does the voltage on the pink wire stay the same ?

Customer: replied 1 year ago.
No it pulsates
Customer: replied 1 year ago.
On The pink wire from the coil
Expert:  jazzmaster replied 1 year ago.

ok, does it pulsate from around 9.5 volts or so ?

Customer: replied 1 year ago.
I will check that in morning
Expert:  jazzmaster replied 1 year ago.

ok, please let me know

Customer: replied 1 year ago.
Thank you
Expert:  jazzmaster replied 1 year ago.

you are very welcome ,in the meantime I will explore this further ,I did have a site where they explained the whole process of this circuit ,...jazzmaster ..

Customer: replied 1 year ago.
hello the GMC that we've been working on and not gaining much ground we have weak spark at the center tower of the distributor cap it will give you a good shock but we have nothing coming out of the disturber cap going to the spark plug wires
Expert:  jazzmaster replied 1 year ago.

the ignition module should be checked anyways .

the reason I say this ,is because even though the part is new ,it still may be bad .please get that checked and see if it is good .

I have been fooled more than a few times by thinking the new parts were good and I kept going round and round trying to fix something when the issue was the new parts ..

and the symptons appeared to be the same ..thanks ..jazzmaster ..

Customer: replied 1 year ago.
I noticed the spark from the coil with the test light it was a very weak from the coil but if I took that test light and also went to ground the flash got much brighter I replace the ignition module as per your instructions but it did not help anything
Customer: replied 1 year ago.
Hi pal I would like to send you a picture of what the problem actually was if you could give me an address so I can send
Expert:  jazzmaster replied 1 year ago.

you should be able to send that on these posts by hitting the paper clip icon ...how did you have the test light hooked up ?

Customer: replied 1 year ago.
i found the ECM only controls timing advance and fuel injection does not control spark probing the two pink wires and two white wires with a ohm meter I found my power was going to ground so opened the coil harness and this little resister and by passed it and truck started right up it started so fast I about fel off the box I was standing on.