How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Tim's Auto Repair Your Own Question
Tim's Auto Repair
Tim's Auto Repair, mechanic
Category: Chevy
Satisfied Customers: 15486
Experience:  Have owned a repair shop for 25 yrs.
14541291
Type Your Chevy Question Here...
Tim's Auto Repair is online now
A new question is answered every 9 seconds

I have a 1992 chevy motorhome with a 454 tbi motor. It runs

Customer Question

hello
I have a 1992 chevy motorhome with a 454 tbi motor. It runs great when its cold but once it hits operating temperature it seems to stutter under load, any thing above half throttle. If your climbing a hill and have WOT it will backfire sometimes but if you let off the throttle it runs fine. Ive changed the CAT, plugs, wires, rotor, distributor cap, O2 sensor, MAP sensor, EGR valve. but the issue still remains! ive read the fuel pump could be the problem but why would it work fine until the engine hits full operating temp? Could the temperature control sensor cause this?
Submitted: 1 year ago.
Category: Chevy
Expert:  Tim's Auto Repair replied 1 year ago.

Hi, My name is ***** ***** for the delay.

I will do my best to assist you

does the engine light stay on?if so,can you give me the trouble codes?

Customer: replied 1 year ago.
the engine light hasnt come on at all
Expert:  Tim's Auto Repair replied 1 year ago.

does the engine light work?does it come on with the key on and engine not running?

Customer: replied 1 year ago.
lol yes the engine light works and yes it comes on with the key on but engine not running
Expert:  Tim's Auto Repair replied 1 year ago.

great..

does it always start well cold?

does t start well hot?

Customer: replied 1 year ago.
It always starts right up hot or cold and runs smoothly. the issue only starts when its at operating temperature and under load. it runs great at cruising speed
Expert:  Tim's Auto Repair replied 1 year ago.

ok

sense the engine light doesnt come on i can give you my thoughts from the way you explain the problem

Expert:  Tim's Auto Repair replied 1 year ago.

from the way you explain,it sounds as if you may have one of two possible problems

Customer: replied 1 year ago.
Okay
Expert:  Tim's Auto Repair replied 1 year ago.

1-the ect[engine coolant temperature ] sensor.

2-the fuel pressure from a bad fuel pump or clogged fuel filter.

PLEASE COPY AND PASTE the link below to your browser, I have uploaded more info on this there please copy and paste the link below to your main browser[INTERNET EXPLORER or FIREFOX]

.

https://www.dropbox.com/s/ltv4sfinlwcpypi/0915-motorhome-Engine%20Wiring%20Harness.doc?dl=0

.

if the link doesn’t work that way, try it this way

thanks

.

www.dropbox.com/s/ltv4sfinlwcpypi/0915-motorhome-Engine%20Wiring%20Harness.doc?dl=0

.

If you are satisfied with my answer, Please Rate my answer by clicking the rating button so I can get credit for my work. I’m not always going to be giving you good news, so please don't let this stand in the way of you accepting my answer. .it does not cost you more money and we will still be able to communicate, ,.please understand, i can not see, hear or touch the vehicle and only know what you tell me. Bonuses and positive feedback are appreciated.. if you are not satisfied with my answer, please do not leave bad feed back ,i will gladly opt out and let another expert handle the question. .if i have sent any diagrams, please print them. .sometimes you may need to right click the image [,then save picture as]to save it to your computer so you can open it with your picture program...Please ask if you need more help

Expert:  Tim's Auto Repair replied 1 year ago.

i would think the problem is the fuel pump,it sounds as if the pump is loosing pressure after it gets hot it is getting weak

thanks

Customer: replied 1 year ago.
That doesnt make sense to me though cause the fuel pump is in the tank so how does it change in temperature? Not saying your wrong but in theory it doesnt make sense
Expert:  Tim's Auto Repair replied 1 year ago.

the fuel pump is electric,,it gets hot when they wear and pull more amps

Customer: replied 1 year ago.
ok, ill check the fuel pressure and the TCS and see what happens thanks
Expert:  Tim's Auto Repair replied 1 year ago.

not the tscs,the ect[engine coolant temperature] sensor

thanks