How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Gary Your Own Question
Gary
Gary, Chevy Technician
Category: Chevy
Satisfied Customers: 15723
Experience:  15 years GM master tech
19513769
Type Your Chevy Question Here...
Gary is online now
A new question is answered every 9 seconds

I have a 1996 Chevy 1500, 4.3 that is giving a lean

Customer Question

I have a 1996 Chevy 1500, 4.3 that is giving a lean condition error and an upstream O2 sensor (bank 1) code.. I have tried spraying throttle body cleaner around the intake gasket and nothing changes. I'm pretty sure that will rule out the intake gasket failure.
Submitted: 1 year ago.
Category: Chevy
Expert:  Gary replied 1 year ago.

I am sorry your having this problem

it is just one code set for bank1 lean NO bank 2 lean codes ?

and no vacuum leaks on that side of the engine ?

Customer: replied 1 year ago.
Also getting a P0300, random missfire code. Yes, just lean from bank 1.
Expert:  Gary replied 1 year ago.

if there are NO vacuum leaks and it is just bank1 doing this then this issue is a bad O2 sensor bank 1 sensor 1 OR there is an issue with the fuel injectors for that bank of cylinders

since it is just that bank 1 and it only has one cat converter it can not be the cat or a fuel pressure issue