How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Lou P. Your Own Question
Lou P.
Lou P., ASE Certified Technician
Category: Chevy
Satisfied Customers: 4087
Experience:  building and driving chevy's since i was in the womb!!!! camaro and corvette enthusiest, access to factory diagrams and tsb's
27644750
Type Your Chevy Question Here...
Lou P. is online now
A new question is answered every 9 seconds

2006 Impala, drove the car this morning, had a "engine hot /

Customer Question

2006 Impala, drove the car this morning, had a "engine hot / turn a/c off" come up on dash. Pulled over and removed battery cable to reset computer. Replaced cable and tried to start engine. As soon as the key was turned I lost all power and then the air blend dampers started to run, dash lights were flashing randomly and you could hear relays clicking in the dash and I could not remove the ignition key. After several attempts to reset the computer and the same thing happening I gave up.Can you tell me what is likely to be the cause?
Submitted: 1 year ago.
Category: Chevy
Expert:  Lou P. replied 1 year ago.

Hello. Sounds to me like either the battery is weak or you did not get the post tightened correctly, if you can twist the cables by hand then they are too loose. Also removing the cable does not fix any fault codes and warning lights. And this is not a recommended procedure for malfunctions that pop up. Let me know about the battery posts. Lou