How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Tim's Auto Repair Your Own Question
Tim's Auto Repair
Tim's Auto Repair, mechanic
Category: Chevy
Satisfied Customers: 15483
Experience:  Have owned a repair shop for 25 yrs.
14541291
Type Your Chevy Question Here...
Tim's Auto Repair is online now
A new question is answered every 9 seconds

4L60E bump in 1-2 shifting and 2-3 shifting after

Customer Question

4L60E bump in 1-2 shifting and 2-3 shifting after transmission rebuild.
Hi,
I have rebuild my 4l60E on my 2003 Chevrolet TAHOE, i have make some mistake in this operation like :
- Not correct set in 3-4 clutch pack. After test on the car, no 3rd and 4th gear
I have replace the 3-4 clutch pack, by a new one, and change 1-2 & 2-3 solenoids, pressure control solenoid and 3-2 solenoids.
The rotor of oil pump has broken, i have replace it.
Now after the 3rd drop-off transmission, there are bump when shifting in 1-2 and 2-3. Cold or warm it's the same. Fluid is GM Dexron VI.
Theses bumps were no present before oil pump service and solenoid replacement.
What is the problem with this transmission ?
Submitted: 1 year ago.
Category: Chevy
Expert:  Tim's Auto Repair replied 1 year ago.

Hi, My name is ***** ***** for the delay.

I will do my best to assist you

does it have all 4 gears now?

does the engine light stay on?if so,can you give me the computer codes?

explain"bump"

thanks

Customer: replied 1 year ago.

Hi,

My name is ***** ***** French. My english can be bad. Sorry about that.

All gears are OK, no slipping in third or fourth.

No "Check Engine" light.

Bump or knock when shifting.

Before rebuild the transmission it was a smooth transmission, i can't feel the gear shifting.

Now, when shifting you feel and heard a knock. No smooth. It's like when you drive in 4Low...

Expert:  Tim's Auto Repair replied 1 year ago.

there is nothing in the transmission to knock,,are you sure the u-joints are good in the drive shaft?,,also,make sure the rear end pinion gear is tight and doesnt have play

Customer: replied 1 year ago.

What to you tell u-joints ?

No problem with the rear end pinion

Expert:  Tim's Auto Repair replied 1 year ago.

the u-joints in the drive shaft,,that connects the transmission to the rear end

Expert:  Tim's Auto Repair replied 1 year ago.

does the it do this hot and cold?

Customer: replied 1 year ago.

The U-joints are goods.

I think my problem come from a bad control of pressure.

Because, the shifting are very fast like a DSG on Volkswagen / Audi cars (you can see the RPM shut down very fast, there is no slip), but hard like Race transmission.

Does i must install shift kit, or valve body upgrade ?

Expert:  Tim's Auto Repair replied 1 year ago.

ok,,

sense it is shifting quickly,,this sounds like maybe a bad throttle possitions sensor,,the 03 year model was the first throttle actuator control [tac] unit,,[it didnt have a throttle cable to the throttle and the tps was built into the tac].

lets try something,,remove the intake air duct and clean the throttle body with carb cleaner,sometimes the throttle body will get dirty and cause a bad tac reading..

i would think you should be getting a code,if cleaning the throttle body doesnt help..replace the pressure switch again

thanks

Expert:  Tim's Auto Repair replied 1 year ago.

If you are satisfied with my answer, Please Rate my answer by clicking the rating button so I can get credit for my work. I’m not always going to be giving you good news, so please don't let this stand in the way of you accepting my answer. .it does not cost you more money and we will still be able to communicate, ,.please understand, i can not see, hear or touch the vehicle and only know what you tell me. Bonuses and positive feedback are appreciated.. if you are not satisfied with my answer, please do not leave bad feedback ,i will gladly opt out and let another expert handle the question. .if i have sent any diagrams, please print them. .sometimes you may need to right click the image [,then save picture as]to save it to your computer so you can open it with your picture program...Please ask if you need more help.

Customer: replied 1 year ago.

i will try to replace the pressure switch, and come back to you when i receive it ( about 3 days )

Thank you

See you later

Expert:  Tim's Auto Repair replied 1 year ago.

clean the throttle body first,,a dirty throttle body can do this

thanks

Customer: replied 1 year ago.

The throttle body is clean.

If i must replace the TB, i have a new throttle body not installed, because i don't know if programing is necessary.

I buy all parts on Rockauto, and receive them 3 days after. I will test the pressure switch. I have never replace this parts before.

Expert:  Tim's Auto Repair replied 1 year ago.

ok..there is no need to reprogram the TB..or the transmission after the rebuild,,

again,this is providing you are sure the transmission is rebuilt correctly

thanks

Customer: replied 1 year ago.

Hi,

I have received all parts and change all :

- New TB

- New TCC solenoid

- New Pressure switch

- New Transgo shift kit (orange box)

Now, when cold the transmission is smooth and no harsh shifting. But after driving 15 miles, the harsh shifting come back.

Any help please.

Expert:  Tim's Auto Repair replied 1 year ago.

still no engine light?

Expert:  Tim's Auto Repair replied 1 year ago.

was a shift kit installed during the rebuild?

Customer: replied 1 year ago.

No engine light.

Shift kit installed last week. Because harsh shifting after rebuild.

After replacing all parts and shift kit. The transmission is smooth only during 15 miles.

After 15 miles driving, harsh shifting.

Expert:  Tim's Auto Repair replied 1 year ago.

ok..sense there is no engine light and from the way you explain,,

you must know that the shift jit will make it shift firmer and may be a little harsh,,but,,sense you say it only does this after it gets warm,it could have a small internal pressure leak from a seal or sealing ring inside the transmission,the fluid is much thicker when cold,when you drive it a little while,the fluid gets hot and this,thus may be loosing a little pressure after the fluid gets hot and thin..

you may want to have your dealer run a update on the pcm[computer] but the problem may be internal.

again,the shift kit will make it shift firmer than stock

thanks