How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Anthony Your Own Question
Anthony
Anthony, Chevy Technician
Category: Chevy
Satisfied Customers: 11750
Experience:  GM Certified
15218643
Type Your Chevy Question Here...
Anthony is online now
A new question is answered every 9 seconds

Chevrolet 2500 HD: Bill I'm working on a 2003 Chevy

Customer Question

Hello Bill
I'm working on a 2003 Chevy with the 6.6 LB7 it has 3 trouble code first is P0380 for glow plugs 2 P0641 5 volt reference 1 circuit and the 3 P1125 Accelerator Pedal Position system
From what I have found the APP only has 2volts and the Fuel Rail Pressure sensor has the same 2 volts
Submitted: 1 year ago.
Category: Chevy
Expert:  Tool Hut replied 1 year ago.
Hi, My Name is***** have over 20 years experience repairing vehicles. I am a ASE Certified Master Auto Technician. I am confident we can resolve your problem together.Please remember I don't know your skill level. I can't see, smell, hear, or touch the vehicle. It may take a few back and forth replies to get to a satisfactory resoloution. Try your best to respond with good detail so I can do the same.So I assume you have access to a scanner? Is this a safe assumption? For reference their should be 3 APP voltages. and they should all change when the throttle is pressed. The values wont be the same. They should all change though. The fuel rail pressure should also change as the engine speed increases. Can you verify that these are happening? We will come back to the glow plug code later.
Customer: replied 1 year ago.
Hello Sam
Yes I have a Tech 2 scan tool but I'm not very good with it I do know my way around the tool a little but haven't used it muchSo last night I had unplug a couple plug that are mounted just above the valve cover on the left side/ driver side to get to the Fuel Rail Pressure sensor and I replugged everything is and all the sudden I had 5 volts back at the FRP sensor the pickup start and ran just fine
then this morning started the pickup and no codes except for the glow plug code backed it out and started to drive it and it came back with the same codes and reduced power and was running very rough and then died the pickup will start then die and sometime will start and run very rough for 30 sec I've looked at the plugs I had unplugged pretty close and don't see anything wrong I've wiggled the wires to see if when it is run if it will smooth out and No changelast night after the 5 volts come back the APP all 3 sensor seemed fine and the FRP sensor changed with engine speed
Expert:  Tool Hut replied 1 year ago.
OK, the fuel pressure sensor code is not a big concern I don't think. Lets work on the APP and Glow plug codes. I suspect when you get these resolved the other will go away. In the glow plug module you will see different resistances for the glow plug. I am looking for 1 that is 0.0 or way higher than the rest. Do you see any like that? The APP code I suspect is intermittent and you will need an APP
Customer: replied 1 year ago.
Ok I'm not familiar with the glow plug system so where should I look
for the glow plug module ? And will I be testing across 2 wire for resistant ?
Just a question does the glow plug problem have any thing to do with the p0641 5volt reference code or the p01125 APP code ?
Expert:  Tool Hut replied 1 year ago.
Under powertrain there should be a glow plug control module. In there is a data list and it should have resistance values. P1125 I suspect is going to be a bad APP Sensor. If you have a glow plug shorted to ground it could cause all of your problems. I just want to get some clarification on what the vehicle has for data right now.
Customer: replied 1 year ago.
so i just look this morning the only thing I can find is glow plug feed back signal and you can command them on and it says it a California system
there was no place for resistant values
The Feed back signal when the Key is on it always has .5 volts
Expert:  Tool Hut replied 1 year ago.
When you are in the tech 2 it doesnt have a glow plug control module listed?
Customer: replied 1 year ago.
Nope there is no listing for glow control plug module
Expert:  Tool Hut replied 1 year ago.
I am going to opt out and see if a different expert can assist you.
Expert:  Anthony replied 1 year ago.
Hello, different expert here..Is the wiring ok between the app, the FRP and the engine computer?
Customer: replied 1 year ago.
Hey athony
Sorry I've been very busy !!
Is there a pin diagram for the wire that go from the FRP sensor and the ECM ? And the same for the APP to the ECM ?
I will visually inspect the wiring to make sure there is not bad spots
Expert:  Anthony replied 1 year ago.
Hello!Yes, heres both: