How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask BOBBYSS Your Own Question
BOBBYSS
BOBBYSS, Master Technician
Category: Chevy
Satisfied Customers: 17142
Experience:  ASE MASTER CERTIFIED, AA DEGREE AUTO/DIESEL TECH
1627031
Type Your Chevy Question Here...
BOBBYSS is online now
A new question is answered every 9 seconds

Chevrolet Lumina LS: I have a 97 lumina with 164000 miles.

Customer Question

I have a 97 lumina with 164000 miles. I have put a lot of new parts in it, crank sensors, cam shaft sensor, o2 sensors, ecm, to many to list ,The motor has the notorious piston slap and has been that way for some time. A couple of days ago I replaced the throttle body gasket because I thought it was leaking vacumn. So then headed to the mechanic to see about knocking out the check engine light, He scanned it and said it was the camshaft sensor, I just put one less than a month ago. He said where did you get auto zone? I couldnt rember. He said spend the xtra funds from napa or pep boys ,so for 38 bucks I had one from pep boys. Did that and again headed back to shop but on the way over there the the low oil came, wasnt to concerend,maybe another sensor.It finally went off. On the way home 5 blocks and in the left turn lane It stops running. I had one hell of a time trying to keep it running ,then would quit. Got out and start pushing across the intersection. Anyway the car is in garage now and it will start right up but the oil indictor stays on and motor sounds like theres no oil getting to the lifters. could the problem b the oil pump or when I replaced upper and lower intake gasket a while back the oil pump pick up shaft dropped back down into the cavity. Is there a plastic clip that holds the pickup tube to the pump that could have gotten broken? There is oil in. Idont really want to junk the car but not much money either. By the way Ive done all repairs myself Thanks
Submitted: 1 year ago.
Category: Chevy
Customer: replied 1 year ago.
its also a 3.1
Customer: replied 1 year ago.
(Posted by JustAnswer at customer's request) Hello. I would like to request the following Expert Service(s) from you: Live Phone Call. Let me know if you need more information, or send me the service offer(s) so we can proceed.
Expert:  BOBBYSS replied 1 year ago.
Hello, my name is Bobby. Thank you for the question. If the oil pump pick up is not attached to the pump then this can definitely occur. It sounds like you have no oil pressure. This will cause the engine to make noise and shut down as a fail safe due to the lack of oil pressure. I would see if the pick up is in place. If it is then replace the oil pump. Let me know if you need more help.

Related Chevy Questions