How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris (aka-Moose) Your Own Question
Chris (aka-Moose)
Chris (aka-Moose), Technician
Category: Chevy
Satisfied Customers: 44516
Experience:  16 years of experience
2499435
Type Your Chevy Question Here...
Chris (aka-Moose) is online now
A new question is answered every 9 seconds

Chevrolet Aveo: again I have a 2004 aveo vehicle had

Customer Question

Hello again I have a 2004 aveo vehicle had an issue that when you first started the car it would race to 3500 rpm plus the car would not shift into over drive I spoke with another tech from answers who was somewhat helpful but didn't follow through . I fixed the rev problem and the trans I realize is connected t that cold start now it starts fine and goes into over drive my problem now is that you drive it for 5 minutes and it throws the same codes plus for some reason the cold start relay shorts out that's the large 4 prong located inside the car lower left hand side Thanks again dom
Submitted: 1 year ago.
Category: Chevy
Expert:  Chris (aka-Moose) replied 1 year ago.
I am sorry for the delay in getting a response to you. Sometimes we get alot of customers and just can not keep up. Sometimes you just have to wait for the correct tech to login.Do you even still need help. Sometimes customers seek help elsewhere or figure it out on their own before we get to each and everyone.I am sure I can help a lot or a little at least something if you give me a chance and work with me. I am going to get an answer to you regardless if you reply or not sooner or later.If your concern is urgent reply and let me know and if you have anything more you think will help me, to help you, let me know. I work on here normally 3pm-3am central. Thanks Chris
Customer: replied 1 year ago.
Hello Chris we spoke a few times before you were very help full each time fortunately I realized the temp sensor if not working properly will cause the engine to race and create issues with the over drive and a lot of other problems repaired the wireing which was pulled when the serpent belt and tensioner broke replaced damage sensor and wella I'm a hero everything works Thanks again for your time. Be well dom
Expert:  Chris (aka-Moose) replied 1 year ago.
Glad you got it resolved, keep in touch for a future issue you think I can help on.