How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Dan Your Own Question
Dan
Dan, Technician
Category: Chevy
Satisfied Customers: 23591
Experience:  Independent Shop Experience, 2 Year Automotive Diploma, & Access to Information Database
17871496
Type Your Chevy Question Here...
Dan is online now
A new question is answered every 9 seconds

Chevrolet Impala LS: my beams will not come on 2005 Impala,

Customer Question

my hi beams will not come on 2005 Impala, brand new assemblies. old assembly doesn't work either
Submitted: 1 year ago.
Category: Chevy
Expert:  Dan replied 1 year ago.
Hello, my name is ***** ***** I'm here to help get your problem solved. It sounds like your body control module may have failed which sends ground signal to the headlights. You can unplug the body control module and ground pink wire at pin B10. If this causes hi beam to come on then body control module has failed which needs to be replaced/reprogrammed at dealership and around $500 job. Let me know if you have more questions, thanks.
Customer: replied 1 year ago.
well, it is a short SOMEWHERE. (?) my mechanic tested and got a 14 reading on low beam, and 14 on high beam, and the either connection, or the switch got really hot. so it's low beams until he can find the short. He traced from the headlights to the firewall, then went on vacation!!
Expert:  Dan replied 1 year ago.
Check for poor terminal contact at connector C106, a black 30 pin lever lock connector in the right side of the engine compartment. It is attached to the chassis across from the serpentine belt area of the engine. Also check wiring harness under battery tray, battery will need to be removed to access. Let me know how it goes, thanks.
Customer: replied 1 year ago.
I looked at the harness and found a pink wire that has a horizontal split in the covering, it isn't broken through. There are no wires under the battery, all around it, not under.
I attached a jpg. could it be THAT SIMPLE?
Thanks
Expert:  Dan replied 1 year ago.
Here is a wire diagram to help with testing, it sounds like you may be better off running a new wire to replace shorted wire. Let me know how it goes or if you have more questions. Thanks.
-
https://www.dropbox.com/s/wo73lrcnwxgg67a/hl.svg?dl=0
-