How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Tim's Auto Repair Your Own Question
Tim's Auto Repair
Tim's Auto Repair, mechanic
Category: Chevy
Satisfied Customers: 15481
Experience:  Have owned a repair shop for 25 yrs.
14541291
Type Your Chevy Question Here...
Tim's Auto Repair is online now
A new question is answered every 9 seconds

I have a 01 chevy s10 w/ a 4.3 lit vortec. the eng finally

Customer Question

i have a 01 chevy s10 w/ a 4.3 lit vortec. the eng finally started but now i have a dtc P0200 fuel inj malfunc..
Submitted: 1 year ago.
Category: Chevy
Expert:  Tim's Auto Repair replied 1 year ago.
Hi, My name is ***** ***** for the delay.
I will do my best to assist you
please explain..does the engine run well?
tell me all you can
thanks
Customer: replied 1 year ago.
Runs rough like it has a hi perf cam.shakes! No misfire codes.
Expert:  Tim's Auto Repair replied 1 year ago.
is the 200 code the only code you get?
Customer: replied 1 year ago.
Yes
Expert:  Tim's Auto Repair replied 1 year ago.
ok,,stand by for a moment,,
Expert:  Tim's Auto Repair replied 1 year ago.
ok..you need to check the wire harness plug behind the throttle body,,make sure the connection is clean and tight
Expert:  Tim's Auto Repair replied 1 year ago.
but,,your problem may be a bad fuel meter mbody[spider]
Expert:  Tim's Auto Repair replied 1 year ago.
PLEASE COPY AND PASTE the link below to your browser, I have uploaded more info on this there please copy and paste the link below to your main browser[INTERNET EXPLORER or FIREFOX].https://www.dropbox.com/s/0377um0ltq2rid5/0710-2001-s10-P0200.doc?dl=0.if the link doesn’t work that way, try it this waythanks.www.dropbox.com/s/0377um0ltq2rid5/0710-2001-s10-P0200.doc?dl=0. If you are satisfied with my answer, Please Rate my answer by clicking the rating button so I can get credit for my work. I’m not always going to be giving you good news, so please don't let this stand in the way of you accepting my answer. .it does not cost you more money and we will still be able to communicate, ,.please understand, i can not see, hear or touch the vehicle and only know what you tell me. Bonuses and positive feedback are appreciated.. if you are not satisfied with my answer, please do not leave bad feed back ,i will gladly opt out and let another expert handle the question. .if i have sent any diagrams, please print them. .sometimes you may need to right click the image [,then save picture as]to save it to your computer so you can open it with your picture program...Please ask if you need more help
Customer: replied 1 year ago.
The inj body is a rebuild 1 fr rebuilders specialty.
Expert:  Tim's Auto Repair replied 1 year ago.
still yet..if it isnt the wiring,,i think your spider is bad
Customer: replied 1 year ago.
I ck for 12v & ground @ the inj harness. I see 12v but no ground. Going to ck w/ inj noid for pulses.
Expert:  Tim's Auto Repair replied 1 year ago.
ok..follow the procedure i sent in the linkthanks
Customer: replied 1 year ago.
Ck inj utilizing inj noid testor. Blinks when cranking. Ck inj connector found it not pushed down all the wy.. eng starts,runs, & no shakes. Turn off engine & ck for any dtc s . Found p0300 multi misfires.has nu plugs,wires,cap n rotor.
Expert:  Tim's Auto Repair replied 1 year ago.
ok
are you sure about the fuelpressure,,it must have no less than 55psi at all times
Customer: replied 1 year ago.
Key on jumps up to 62psi & settles @56-58 psi..
Customer: replied 1 year ago.
The spec is 60-66 psi..
Expert:  Tim's Auto Repair replied 1 year ago.
how much while running,,?
Expert:  Tim's Auto Repair replied 1 year ago.
is the 300 the only code you get now?
Customer: replied 1 year ago.
Let me ck the fuel press while running.
Expert:  Tim's Auto Repair replied 1 year ago.
ok..also give it throttle...tell me igf the pressure drops or risesthanks
Customer: replied 1 year ago.
Raise throttle-53psi,@idle -56psi..
Customer: replied 1 year ago.
No more dtc but the yellow led is on on emission stats.
Expert:  Tim's Auto Repair replied 1 year ago.
okyour pressure is way too low
Expert:  Tim's Auto Repair replied 1 year ago.
i would think you have a weak pump,,the pressure should rise when you give it throttle
Expert:  Tim's Auto Repair replied 1 year ago.
PLEASE COPY AND PASTE the link below to your browser, I have uploaded more info on this there please copy and paste the link below to your main browser[INTERNET EXPLORER or FIREFOX].https://www.dropbox.com/s/y4ilhojco7owhzj/0711-s10-P0300.doc?dl=0.if the link doesn’t work that way, try it this waythanks.www.dropbox.com/s/y4ilhojco7owhzj/0711-s10-P0300.doc?dl=0. If you are satisfied with my answer, Please Rate my answer by clicking the rating button so I can get credit for my work. I’m not always going to be giving you good news, so please don't let this stand in the way of you accepting my answer. .it does not cost you more money and we will still be able to communicate, ,.please understand, i can not see, hear or touch the vehicle and only know what you tell me. Bonuses and positive feedback are appreciated.. if you are not satisfied with my answer, please do not leave bad feed back ,i will gladly opt out and let another expert handle the question. .if i have sent any diagrams, please print them. .sometimes you may need to right click the image [,then save picture as]to save it to your computer so you can open it with your picture program...Please ask if you need more help
Customer: replied 1 year ago.
Make s sense . I'll change out the pump n let you know. Thanx!
Expert:  Tim's Auto Repair replied 1 year ago.
ok..check the pressure on the new pump also,,it is very common to get a bad/weak new pump for these votec enginesthanks
Customer: replied 1 year ago.
Installed nu pump - key on 58psi, eng @ idle 58psi, eng @ Rev 55psi..
Expert:  Tim's Auto Repair replied 1 year ago.
the pressure should rise when you give it throttle