How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask GM Tech (Cam) Your Own Question
GM Tech (Cam)
GM Tech (Cam), Chevy Technician
Category: Chevy
Satisfied Customers: 15181
Experience:  GM Grand Master Technician 2007. 14 years experience.
10949255
Type Your Chevy Question Here...
GM Tech (Cam) is online now
A new question is answered every 9 seconds

Chevy S10: I removed my secondary air pump from my 2201 chevy

Customer Question

I removed my secondary air pump from my 2201 chevy s10 and no w it starts and runs but won t accelerate , what s wrong?
Submitted: 1 year ago.
Category: Chevy
Expert:  Gary replied 1 year ago.
I am sorry for the long waitso this truck ran fine before you removed the secondary air pump ?you just remove the pump and the tube at each manifold and blocked it off and now its doing this ?are there any codes set at all in the computer ?
Customer: replied 1 year ago.
I removed my secondary air pump tubes from the exhaust manifold and made some metal blanks to cover the holes in the exhaust manifold because the rubber like connection began to melt and leak exhaust gases . So I thought I could just take off the air pump tubes since the air pump had been disconnected before I bought the truck, the tubes have termostats in them that went out and let hot gases out when they weren't suppose to and that s what cause the melting. The truck ran great up untill a week ago. I haven't had it hooked up to any diagnostic equipment yet I can t get it there the truck won t accelerate I give it gas and it bogs down it doesn't quit but it won t accelerate.
Expert:  Gary replied 1 year ago.
ok so it ran ok for a while after you did that work with the air pump correct ? and seemed to run for for a while ?
Customer: replied 1 year ago.
No , I took off the tubes and it wouldn t go .I think it s a vacuum leak somewhere but I m not sure.
Expert:  Gary replied 1 year ago.
can you just be sure fuel pressure is 60 PSI key ON engine OFF and that the PSI holds for a little bit