How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask GM Tech (Cam) Your Own Question
GM Tech (Cam)
GM Tech (Cam), Chevy Technician
Category: Chevy
Satisfied Customers: 29427
Experience:  GM Grand Master Technician 2007. 14 years experience.
10949255
Type Your Chevy Question Here...
GM Tech (Cam) is online now
A new question is answered every 9 seconds

Chevrolet K2500 4x4: got an 2004.5 duramax lly it wont start

Customer Question

got an 2004.5 duramax lly it wont start it cranks fires for a second then dies no engine light no codes either except for the glow plug mod i replaced fuel filter primed it bleed the air out still doing the same thing
Submitted: 1 year ago.
Category: Chevy
Customer: replied 1 year ago.
could it be the ignition switch cause the security light comes on when it dies
Expert:  GM Tech (Cam) replied 1 year ago.
Hi there, I am Cam. Can I get your first name please? The security is a very likely issue. Starting and stalling with in that period of time is usually security. Can I ask if you have anything like a remote starter installed?
Expert:  GM Tech (Cam) replied 1 year ago.
To speak to your comment about the ignition switch, the switch itself is not part of the security system, however you are very close. There is a security sensor in the housing of the ignition cylinder that senses the rotation of the cylinder to monitor what is actually happening. If that sensor has failed, then lets look at possibly a relearn procedure that may be all it needs. Turn the key on and attempt to start the car, It may crank, it may start and stall or it may do nothing at all, this is fine, still cycle the key to start then release the key back to run. Wait 10 minutes with the key in run. The passlock light should be flashing and the DIC will say "Service Vehicle" or "Security" or have a picture of a car with a lock during that 10 minute span.After 10 minutes has passed, turn off the car, count to 10, and try to start it again and release the key back to run.Wait another 10 minutes.After 10 minutes, turn car off 10 seconds and try to start again and release the key to run.Wait another 10 minutes.After 10 minutes, turn car off 10 seconds and try to start again.It should start up this time. The passlock has been learned.During this process, turn the fans off, radio off and cycle the headlights off so the battery will not go dead. If needed, use a battery charger.
Customer: replied 1 year ago.
it dosnt have the passlock light on once you you crank it and it fires then stalls then the light comes on then goes out
Expert:  GM Tech (Cam) replied 1 year ago.
Ok How about the addition of a remote starter?
Customer: replied 1 year ago.
theres no remote starter the problem first occured when i was driving down the road and sputtered a little then died
Expert:  GM Tech (Cam) replied 1 year ago.
Ok, If it stalled while driving then its not the security. Security only makes it stall within 2 seconds of starting. SO lets look elsewhere. IF you pump the plunger on the fuel filter, does fuel come out of anywhere? The bottom of the filter and such? Also if you pump the plunger, does it remain running?
Customer: replied 1 year ago.
it will run a little longer after i let it sit with the key in the run position and if i prime it it dose get hard
Expert:  GM Tech (Cam) replied 1 year ago.
Ok, so no leaks though? Are there any power up devices installed?
Customer: replied 1 year ago.
no leaks and no power ups installed
Expert:  GM Tech (Cam) replied 1 year ago.
OK, how many miles? Did it stall doing this all at once or did it happen a bit over time? Also did you just get fuel?
Customer: replied 1 year ago.
225xxx miles stalled all at once and i did just fill up the day before on my way to work and then dorve home 30 mins and then it happened the next day while driving around town
Expert:  GM Tech (Cam) replied 1 year ago.
Any previous repairs recently?
Customer: replied 1 year ago.
no i had a lift installed but dont think that would cause an engine issue
Expert:  GM Tech (Cam) replied 1 year ago.
How long before this did you have it installed?
Customer: replied 1 year ago.
back in February
Expert:  GM Tech (Cam) replied 1 year ago.
Ok so not recent. Back to pumping it, if you kept pumping the plunger, did it keep running?
Customer: replied 1 year ago.
no it did not
Customer: replied 1 year ago.
when it first happened i did try starting it again and hold it to the floor to see if it would keep running but it did not still died
Expert:  GM Tech (Cam) replied 1 year ago.
OK, so this does not have a lift pump unless you installed one. so it does not get fuel except from the engine pulling it up from the tank. So when you open the bleeder and pump, does raw fuel come out or does it get lots of air in there?
Customer: replied 1 year ago.
raw fuel comes out
Customer: replied 1 year ago.
could it be the FPR cause i do hear a small ticking sound thats coming from the around the alternator area when it stalls and dies
Customer: replied 1 year ago.
is that a normal sound
Expert:  GM Tech (Cam) replied 1 year ago.
Ok, I am thinking you have a problem with maybe the crank sensor or the wiring to it, or possibly even the fuel module. No codes makes it even more difficult. IF I was working on this in my bay I would be watching the actual fuel rail pressure as read with the scan tool. it needs to be 1450 psi just to start. It could be the relief valve. If you pull the U snapped hose off the back of the drivers side fuel rail, does fuel come out of the rail?
Customer: replied 1 year ago.
i did watch the FRP on the scan tool and it was building up to 6000 psi which was the desired psi it was showing
Expert:  GM Tech (Cam) replied 1 year ago.
OK so that is good. Does it show an RPM from the crank signal?
Expert:  GM Tech (Cam) replied 1 year ago.
Better yet, follow this diagnostic.
Expert:  GM Tech (Cam) replied 1 year ago.
I need to step away from my computer for a bit. Work through this chart and let me know where you get and what the results are.
Customer: replied 1 year ago.
ok i went back in and now its showing code U0105 for injector control module
Expert:  GM Tech (Cam) replied 1 year ago.
Sorry for the delay, I am back. This means the module on the front of the passengers side valve cover may have a bad wire going to it, fuse out or the module is bad. They are common for going bad. They are a plug and play unit, so you can replace it and simply install it and it will run if its bad.
Customer: replied 1 year ago.
ill get back to you after the weekend i work on the railroad and gone for days at a time
Expert:  GM Tech (Cam) replied 1 year ago.
Please be sure to save this page as a favorite in your web browser so you can reply back to me easily. you can reply at an time, even after accepting or rating me.