How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Gary Your Own Question
Gary
Gary, Chevy Technician
Category: Chevy
Satisfied Customers: 15703
Experience:  15 years GM master tech
19513769
Type Your Chevy Question Here...
Gary is online now
A new question is answered every 9 seconds

Chevrolet: 91 Buick regal with a 3.1 L motor engine code 12

Customer Question

91 Buick regal with a 3.1 L motor engine code 12 and we change the fuel filter thinking it might be the pomp and we have 40 pounds of PSI
Submitted: 1 year ago.
Category: Chevy
Expert:  Gary replied 1 year ago.
What is the problem you are having with the car ?
Customer: replied 1 year ago.
It dies on its own starts up put in gear and it dies again
Expert:  Gary replied 1 year ago.
it will not die unless you put it in reverse or drive ?
Customer: replied 1 year ago.
Seems that wY I drove around for 5 min and it died 3 times after idling for 20 min with no problem
Expert:  Gary replied 1 year ago.
If you disconnect the TCC connector at the front of the transmission will it still do this ?
Customer: replied 1 year ago.
Where is Tcc connector
Expert:  Gary replied 1 year ago.
front of the transmission near the cooling fan just like the picture i sent
its a 4 plug square connector
its the only one of the front of the transmission pointing at the cooling fan
Customer: replied 1 year ago.
Runs worse won't even move have engine code 34 now
Expert:  Gary replied 1 year ago.
it should nt run worse or set any codes if you unplugged the square 4 wire connector on the front of the transmission as seen in the picture
i think you unplugged the wrong thing
Customer: replied 1 year ago.
This is a 5 pin
Customer: replied 1 year ago.
Ur tran pic looks nothing like my transmission
Customer: replied 1 year ago.
Hello
Expert:  Gary replied 1 year ago.
it should be a 4 pin
not a 5 pin
Customer: replied 1 year ago.
This is a 4 speed auto 3.1 L
Customer: replied 1 year ago.
It's a 5 pin but I don't no how to send u the photo
Customer: replied 1 year ago.
I have it on Jack stands can clearly see all I see is this 5 pin connector on front of trans close to the top I took photos but don't no how to send them to u
Customer: replied 1 year ago.
My tranny pan looks different than its also

Related Chevy Questions