How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Randall C Your Own Question
Randall C
Randall C, ASE Master Tech
Category: Chevy
Satisfied Customers: 12743
Experience:  ASE Master, L1, 32 years, Diagnostic / Electrical Specialist
13677702
Type Your Chevy Question Here...
Randall C is online now
A new question is answered every 9 seconds

I have a 2007 Chevy Equinox that will get hot every now and

Customer Question

I have a 2007 Chevy Equinox that will get hot every now and then. Sometimes it will go 5 months, sometimes 3 weeks, always just random. My mechanic changed the thermostat, the check engine light was on, and it showed the egr valve needed changed, so he
did that. Last time it did it, we stopped at the mechanics place right away and he was able to look at it while it was happening. The fan wasn't running, but when he turned on the air conditioning it kicked on. There were no codes about overheating. The gauge
was at the top end, but no light has come on yet. Any idea what might be causing this???
Submitted: 1 year ago.
Category: Chevy
Expert:  Randall C replied 1 year ago.
Hello, I am Randall Sorry for the delay, Its a bit complex to explain how the whole system works but,, Trying to simplify. you have a coolant sensor, then 4 different fan relays that do the fans from low to high etc and then the ECM (computer) that controsl the fans as needed, If guage was near top and no fans?BUT have fans in AC?> this means fans and relays are ok so,, stpe one is to swap out the coolant temp sensor BUT.. a shop can read coolanat temp on a scanner and even command the fans on over riding the computer persay. With fans ok, relays ok, I have to lean to the coolant temp sensor. BUT be advised the ECM may? not be seeing the sensor signal and commanding the fans on when it gets hot but the AC command is ok. Again, hard to explain.I am feeling temp sensor, but possible ECM circuit so have to at least mention this, The sensor is at the rear of the right side head as shown in the picture link I included
Customer: replied 1 year ago.
I will need to take it to the mechanic and see if this fixes the problem. I will let you know what I find out. Thanks!
Expert:  Randall C replied 1 year ago.
It really has to be one or the other based on what you asked, and symptoms, Thanks
Customer: replied 1 year ago.
sorry but it will be next week until i will be able to get it in to the mechanic, so i will get you rated then. thanks for your help so far!
Expert:  Randall C replied 1 year ago.
ok
Customer: replied 1 year ago.
Hi Randall. Ok - changed out the coolant temp sensor. That didn't change a thing:( So he had a company come out and remove the dash to scan. He said what they ended up changing was a part about the size of an SD card like you would put in your camera. So... how am I supposed to rate your answer?
Expert:  Randall C replied 1 year ago.
well, without knowing what part was changed? I am not sure what was found, I have no idea as to what your reply refers to,I sent options , Sorry I could not be 100%, that is/was not possible so what was found on the scan? why was dash removed? do you have any other detailed information?
Customer: replied 1 year ago.
I will try to find out on Monday which part it was. It was a part in the dash. The last week or two the problem was very consistent. The part they found in the dash and changed fixed the problem. He said it was about the size of an SD card like you use in a camera. You have no idea what it might have been?
Expert:  Randall C replied 1 year ago.
Honestly? none at all, Please, get back to me, I am not aware of any part matching that description , behind dash to prevent fans
Customer: replied 1 year ago.
will do sir
Expert:  Randall C replied 1 year ago.
thanks
Customer: replied 1 year ago.
ok. here is what my mechanic said they ended up doing. Pulled center of dash out where the gauges are. It was the piece that sends info to the computer. The company that came out to scan it called it a motor? It was an electronic piece. It was soldered on back of the instrument cluster. Now... what should I rate you???
Expert:  Randall C replied 1 year ago.
you do not have to rate I honestly do not know what they refer to, Now,, if it was only a guage problem, this is different but fan not working? it is not tied into anything directly at the cluster.I will have the post closed, Did what I could, hard not being there , scanner in hand etc,
Customer: replied 1 year ago.
totally understand what you are saying. also want to be fair to you. shall I rate you ok or will that hurt you?

Related Chevy Questions