How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask GM Tech (Cam) Your Own Question
GM Tech (Cam)
GM Tech (Cam), Chevy Technician
Category: Chevy
Satisfied Customers: 15181
Experience:  GM Grand Master Technician 2007. 14 years experience.
10949255
Type Your Chevy Question Here...
GM Tech (Cam) is online now
A new question is answered every 9 seconds

Chevy Cheyenne: I have a 89 Chevy 1500 Change the fuel pump

Customer Question

I have a 89 Chevy 1500 Change the fuel pump filter and scream i go it to bust off twice but would never stay running
Submitted: 1 year ago.
Category: Chevy
Customer: replied 1 year ago.
Also have changed the wiring harness relay fuse
Expert:  jazzmaster replied 1 year ago.
what is the specific issue you have with this ? 5.7 liter ?
Customer: replied 1 year ago.
I changed the fuel pump filter wiring harness relay fuse screen it will try to crank but want stay running
Expert:  jazzmaster replied 1 year ago.
so they gave a new connector and wiring to splice to the original wiring ?
will this start and run for a second with carb spray ?
do you hear the fuel pump run when to turn the key on to run for 2-3 seconds with out cranking the motor over ?
Customer: replied 1 year ago.
No won't stay running try's to crank but still acting like it ain't geting fuel and the injectors ain't firing I dont think
Customer: replied 1 year ago.
I didn't insta the wiring harness
Expert:  jazzmaster replied 1 year ago.
do you hear the fuel pump running when you turn the key from off to the run position for 2-3 seconds ,this should do that each time ..?
did you check for injector pulse and hot ?
Customer: replied 1 year ago.
Nope and I couldn't really hear the fuel pump I'm death I one ear but this is the second brand new one put in it so surely the pump is good what exactly do you mean by the hot could you explain what wire you r talking about if ya don't mind thanks
Expert:  jazzmaster replied 1 year ago.
the white and the red wires at the injectors should show bat voltage with the key in the run position or while cranking the motor over .
The other wire at each injector should show a pulsating ground signal when cranking the motor over .
the use of a noid light to check for injector pulse is a good thing to have to check both these circuit at the same time ..
So ,you didn't check the new pump to see if it works before putting it in the tank ?
can you see a fine spray of fuel inside the throttle body when you crank the motor over ?
Customer: replied 1 year ago.
Nope Didnt check it and I tried look for the spray Out of the injectors but couldn't see none
Expert:  jazzmaster replied 1 year ago.
check for the injector pulses .
also, check all the fuses and I say this as you may have some blown fuses that you didn't know about.
if there is no hot to the injectors most likely a blown injector fuse is the problem .
Expert:  jazzmaster replied 1 year ago.
hi, I am just checking back to see if I helped you or if you need assistance still .
If I helped you please let me know so I can send you a post to rate me on with a positive smiley face thank you ..jazzmaster ..