How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask BOBBYSS Your Own Question
BOBBYSS
BOBBYSS, Master Technician
Category: Chevy
Satisfied Customers: 17170
Experience:  ASE MASTER CERTIFIED, AA DEGREE AUTO/DIESEL TECH
1627031
Type Your Chevy Question Here...
BOBBYSS is online now
A new question is answered every 9 seconds

Chevrolet C3500 HD Chas/Cab: I have 2012 duramax that I have

Customer Question

I have 2012 duramax that I have owned less than a week. It has given me the "service Emmission system message and reduced my speed to 65 mph. any suggestions as how to resolve this?
Submitted: 1 year ago.
Category: Chevy
Expert:  BOBBYSS replied 1 year ago.
Hello, thank you for the question. Most of the time this is caused by a diesel exhaust filter issue. These can be very expensive to replace. In some cases you can remove it and try cleaning it out and running the truck at a high RPM to clear it out. Most of the time it needs to be replaced though. Did you plan on fixing this yourself?
Customer: replied 1 year ago.
Yes I would like to try and do it myself. How long of a job is it and does it require any special tools?
Expert:  BOBBYSS replied 1 year ago.
You need a scan tool to reset the system. Other than that the filter can be changed fairly easily if you have mechanical experience. It just typically runs quite a bit of money to purchase.
Customer: replied 1 year ago.
Today I unhooked the battery cables for about two hours and touched the positive and negative cables together in an attempt to reset the ECM. After doing this I took it drive the "service emission system" message never came back in but after about 30 miles of driving it now says " service emission fluid system" and has again limited speed to 65. What are your thoughts on it now?
Expert:  BOBBYSS replied 1 year ago.
If that is now the light that is on then the problem may be in the DEF injection system. It is common for the tank to have sludge build up inside and cause this. You can remove the tank and have it cleaned to try and solve it. Hopefully the exhaust filter is fine.