How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask GM Tech (Cam) Your Own Question
GM Tech (Cam)
GM Tech (Cam), Chevy Technician
Category: Chevy
Satisfied Customers: 15181
Experience:  GM Grand Master Technician 2007. 14 years experience.
10949255
Type Your Chevy Question Here...
GM Tech (Cam) is online now
A new question is answered every 9 seconds

Chevrolet Silverado 2500 HD Classic LT: Just installed 8 new

Customer Question

Just installed 8 new injectors on a 05 chevy 2500 hd 6.6. Now no start. Truck came in running now won't run. Have bled lines numerous times. Checked codes and have a u0105. Checked for injector pulse and don't have injector pulse. Checked 2 grounds and 2 power wires at FICM. All are good. Also checked signal wire between ficm and ECM. Light blue wire. That checked fine also. I believe I have a bad ficm but don't understand why. No codes and running fine before injectors were replaced. They were replaced because of an intermittent knocking noise from upper engine per direct hit.
Submitted: 1 year ago.
Category: Chevy
Expert:  GM Tech (Cam) replied 1 year ago.
Hello, I'm Cam.
Can I get your first name please?
Sorry to hear about this issue. Was the engine washed before or after the repair?