How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Kevin Your Own Question
Kevin
Kevin, Auto Mechanic
Category: Chevy
Satisfied Customers: 1889
Experience:  Diagnostic technician
84635724
Type Your Chevy Question Here...
Kevin is online now
A new question is answered every 9 seconds

Chevrolet ext cab not full ext: I have oil lite on replaced

Customer Question

I have oil lite on replaced oil sensor,CP's,CPAs,oil and oil filter,runs great til it reaches lot then starts to run rough then when I slow down or stop the light comes on and off when I give it gas then it gets hotter cause engine perfecting its self I guess and lite stays on . then u start hearing the lifters start chattering . if it was oil pump shouldn't it start chattering rite away when I start it
Submitted: 2 years ago.
Category: Chevy
Customer: replied 2 years ago.
Its got 262000 miles but all Fwy ,I thinking of buying it ,he don't hot rod it he getting up there n age but went to NY twice, Louisiana 4times, Arizona a bunch.truck runs great til it warms up. I looked at other peoples probs but not quite the same and they didn't get all the miles he has. Oh he had new tranny put n ,,not even500 miles ago
Expert:  Kevin replied 2 years ago.
Hi my name is ***** ***** is likely a pressure problem oil gets thinner as it warms and it is possible that as the oil things the engine is struggling to maintain oil pressure . Oil pressure being low can have very expensive results as it will damage bearings inside engine quite quickly .you need to have oil pressure read to see if it is dropping as engine warms if this is the case it is possible that oil pump is starting to fail
Customer: replied 2 years ago.
No pressure at idle and 20 psi at 1200 rpm so gmc says bad service there ,don't know what their talking about for 225 bucks what a waste of money
Expert:  Kevin replied 2 years ago.
The most likely is pump if you have good pressure when engine cold