How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Lou P. Your Own Question
Lou P.
Lou P., ASE Certified Technician
Category: Chevy
Satisfied Customers: 3721
Experience:  building and driving chevy's since i was in the womb!!!! camaro and corvette enthusiest, access to factory diagrams and tsb's
27644750
Type Your Chevy Question Here...
Lou P. is online now
A new question is answered every 9 seconds

Chevrolet Silverado 1500: . I have an issue with my 03 silverado.

Customer Question

Hi. I have an issue with my 03 silverado. Base with v6. Started out as abs light and brake light periodically coming on then going off with the warning chime. Did that for a afternoon , stopped and didn't do it again for about a month. Off and on this would happen then the gas, voltage, temp, and oil pressure gauges would drop and the radio would quit and ac compressor would stop working. Then everything would work again. Chiming every time the lights would come on. Now nothing. No chime, no gauges, no ac, no radio, abs and cel lit. I have checked and cleaned grounds under drivers door and below battery tray. Any thoughts on what may be causing my issues? Thanks
Submitted: 1 year ago.
Category: Chevy
Expert:  GM Tech (Cam) replied 1 year ago.
Hello, I'm Cam.
Can I get your first name please?
Sorry to hear about this issue. Sorry for the delay.
Your thoughts of checking the grounds is a fantastic place to start.
Next I want you to check the ignition switch. There are many feeds in the switch and several share a power source contact.
Do you have a meter? IF so, do this test.
Pop the tilt lever out and take the lower trim of the column off. With your multimeter set to DC volts, place the red lead on the red wire. With the switch turned on, test the other leads with the black wire. Record the reading and let me know what those are. Repeat the test on the red/white wire. Let me know the results. Ideally the yellow has 12V and everything else is nearly 0. IF any are more than 1 volt DC, that means the ignition switch is bad.
Here is a link with the instructions to change it.
https://dl.dropboxusercontent.com/u/22552935/ignition%20switch%20new%20truck.pdf
Check this out and see if this is all you need. If not then please reply back to me.
Customer: replied 1 year ago.
Thanks, there are only 3 wires coming from top of switch. Red/ white stripe , black , yellow. Red lead on red yellow test 8 black test 12. Thanks, Ray
Customer: replied 1 year ago.
Also noticed I have no reverse lights and no interior dome light if that helps in any way.
Customer: replied 1 year ago.
Sorry I missed the green and the tan wires on back of the switch. They both test 12v
Expert:  GM Tech (Cam) replied 1 year ago.
Those are the wrong wires. You're looking at small wires towards the top. There will be all of the wire colors that I mentioned further down in thick wires. Look again and you will find them.
Customer: replied 1 year ago.
So I have 7 thicker wires on the bottom of the switch. 2 reds brown yellow white Orange and purple. Is that them? How do I know which red? No stripe on either.
Customer: replied 1 year ago.
Got it tested all wires using each of the red wires. 12v on yellow. Every other one 0v.
Expert:  GM Tech (Cam) replied 1 year ago.
Ok, next remove the fender brace from the Underhood drivers area, remove the whole black cover from the fuse block to then access the area under the fuse block and inspect for corrosion, rodents and such next.
Customer: replied 1 year ago.
Ok thanks
Customer: replied 1 year ago.
Clean and no corrosion.
Expert:  Lou P. replied 1 year ago.
Hello my name is ***** ***** i will do my best to help you , i strive for EXCELLENT service and nothing more. Have you made and progress ? Did you say the abs and check engine light are in fact lit up in the dash ?
Customer: replied 1 year ago.
No progress, cel light on abs light on, no interior dome light, no reverse lights, fuel, oil pressure, amp meter,temp gauges are flat. No radio but the anti theft light is blinking.
Expert:  Lou P. replied 1 year ago.
Ok , with the ignition on , can you use a test light and check all the fuses in the engine fuse box and right down all the fuse numbers that DO NOT have power ? It sounds to me like a power issue. Or worst case a communication issue between the modules. And do you have a scanner to read the check engine light ? Does the truck start and run ?
Expert:  Lou P. replied 1 year ago.
And I know it's late now , so tomorrow is ok to check this or Whenever you can , I'm here to assist you when you are ready. Sorry the last expert could not help you come to a conclusion. Lou
Customer: replied 1 year ago.
Ok thanks will get back with the info tomorrow
Expert:  Lou P. replied 1 year ago.
Ok , have a good night. Also if you could , do another once over on the truck , check everything that has a switch or a light , we need to know everything that does and does not work. The more info the merrier. Anything you notice you tell me , I'm very good at these issues. Have a good night
Customer: replied 1 year ago.
Truck runs and drives. Gear indicator light on dash is not lit. PRD32L are lit just not the indicator light. These are the fuses that did not light when tested with a voltage tester. Trl/bu. Hi HDLP L, Hi HLDP R, horn and WS Wash. However the horn and WS washer both work.
Expert:  Lou P. replied 1 year ago.
Ok thanks , give me some time to get Back to you. I'll go over a diagram and see what we could check
Customer: replied 1 year ago.
Ok thanks
Expert:  Lou P. replied 1 year ago.
Ok the trl/bu fuse should only have power when the truck is put in reverse. So turn the key on , stop the truck from rolling and put it in reverse and recheck that fuse for power. Also the horn and washer and hi hdlp l/r may also only have power when the actual circuit is activated. But let's focus on the reverse lights and no gear indicator. Let me know. Lou
Customer: replied 1 year ago.
Yeah bu lights have power when put in reverse
Expert:  Lou P. replied 1 year ago.
Ok , I've been going over the diagrams , the signals for everything you have not working all come from the BCM (body control module ) I think that module had failed. So nothing is being activated by it. I'm tracing the wiring and have been for the last hour or so, do you know where the BCM is and what it is ?
Customer: replied 1 year ago.
Under the dash right? Would this also control the gauges?
Expert:  Lou P. replied 1 year ago.
Yes correct and yes correct , it's right where your knees would be. It communicates through a class 2 serial data, so when you turn the ignition switch on it actually sends the signals to the BCM and the BCM is what starts turning everything on and allowing everything to communicate. Same with the gear indicator and dome light. And reverse light. So the issue is within the BCM. The BCM must be bought new and coded to the truck. Unfortunately it cannot be bought used or else the car will not start since the ignition theft system has to match up with a coded BCM. So first I would try removing all connectors and reconnecting and wiggling to make sure it's not just a poor connection. , if none of that helps then the BCM is most likely bad. Hope this information helps Please take a second and click the box and rate my service GOOD OR EXCELLENT SERVICE if you feel I have been helpful and please request me in the future. If you feel I have not been helpful please DO NOT RATE BAD OR POOR AND WASTE YOUR MONEY , I will opt out to see if another expert can provide more or better assistance so you're not wasting your money!!. Thanks for choosing just answer. Lou. also , if you feel i deserve one , BONUSES are GREATLY APPRECIATED ! ūüėČ
If you have any more questions please ask. I am here to help. I am still researching the wiring , the chat will not end once you rate so no worries.
Customer: replied 1 year ago.
So can a used or salvaged bcm be recoded to a different vehicle? Can a faulty bcm be repaired?
Expert:  Lou P. replied 1 year ago.
2 fuses for the BCM are labeled "tbc batt and tbc ign 1" check those to make sure they are not blown
The ground is located on the left side of the dash on the sheet metal pretty much a few inches below the vin. I don't think the ground would be a issue since the car starts. Same with the fuses. Just sounds like the communication part of the module or even a wire is The issue
And no a BCM must be bought new. As far as fixing ? That I am. It sure if I personally don't know if that's a available service.
Expert:  Lou P. replied 1 year ago.
And make sure fuses "ipc/dic" and "seo b1 or 81 " the diagram is fuzzy on that last number. Those fuses are for the serial data. All fuses are in the engine bay fuse box. Not only make sure they are not blown but make sure they have power i know you already have checked but it's always worth a double check.
Expert:  Lou P. replied 1 year ago.
And also you have went over the fuses in the left and right side of the dash to make sure none were blown?
Expert:  Lou P. replied 1 year ago.
Ok last item and suggestion. There have been a few times the issue was the instrument cluster. so it may be worth a check to disconnect it and check the connections for corrosion , and reconnect and see if it comes back to life. The cluster you can switch with another used one to verify , the miles will be off but the cluster can be swapped. I'm pretty confident that the BCM should be the issue. Based on the diagrams that in went over and the issues you have. The reverse lights have nothing to do with the cluster and vice versa now here's another scenario , both the BCM and the cluster have failed giving you two separate issues. It is quite possible. I would to be absolutely sure , go have the truck scanned for codes. If you get communication codes or no communication at all with the cluster or BCM or both then we know they are bad. I've been over and over all the diagrams and I'm starting to think you have more than one failed module. Unfortunately there are not tests for communication wiring when we do not know if there are any codes. We could be chasing our tails until we know a code that will give us a specific test plan. So if you have a junkyard nearby you can try getting a cluster and test fitting it see if it works after you check the connections and wiring at the cluster. Hope this information helps or At least i was helpful. I have taken my time to answer your question the best i could and i will continue to help if you need follow up information , all i ask is that you PLEASE take a second to rate my service so i may recieve my credit for assisting you. Thank you.
Expert:  Lou P. replied 1 year ago.
Did you have any questions to my last few posts ?
Customer: replied 1 year ago.
Sorry not with the truck right now. I will have to contact you later after I can. Check the other items you mentioned.
Expert:  Lou P. replied 1 year ago.
Ok no worries , let me know if you need anything else I will do my best to help. And kindly take a second to rate my service or I will not get credit for assisting. Lou
Expert:  Lou P. replied 1 year ago.
hello, wondering if you needed any more assistance? just checking back. let me know if there is anything i can help with, Lou.