How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Tim's Auto Repair Your Own Question
Tim's Auto Repair
Tim's Auto Repair, mechanic
Category: Chevy
Satisfied Customers: 15700
Experience:  Have owned a repair shop for 25 yrs.
14541291
Type Your Chevy Question Here...
Tim's Auto Repair is online now
A new question is answered every 9 seconds

Chevrolet Silverado 1500 Classic LS: I have a 2000 Chevy 1500.

Customer Question

I have a 2000 Chevy 1500. Runs perfect until it heats up then the transmission will not respond but Rpms go up but no go. Let it sit for 5 minutes and it cools off and it's fine for 10 miles then same thing again ???
Submitted: 1 year ago.
Category: Chevy
Expert:  Tim's Auto Repair replied 1 year ago.
Hi,My name is Tim,
I will do my best to assist you
does it do the same in reverse and in drive?
does the engine light stay on?if so,can you give me the computer codes?
tell me all you can
Customer: replied 1 year ago.
Check engine light was on saying bad knock sensor so I changed them this weekend and the light went off. The code it was giving after that was a low idle code. But the transmission still is doing the same thing in drive and reverse after it warms up. When it is cold it pulls just fine. After I changed the knock sensors though the idle is jumping from 500 to 1500 rpms
Customer: replied 1 year ago.
You still there?
Expert:  Tim's Auto Repair replied 1 year ago.
ok
sense the transmission does pull when it is cold,,
it is loosing fluid pressure,,this is not good at all..
the reason it works cold is the fluid is much thicker..after it heats up,the fluid gets much thinner and looses fluid pressure,a clogged transmission filter could do this and is the only thing you can try from the outside,but,if it isnnt the filter i dont see an easy fix for this,,the transmission will need to be rebuilt or replaced,,sorry
thanks
If you are satisfied with my answer, Please Rate my answer by clicking the rating button so I can get credit for my work. I’m not always going to be giving you good news, so please don't let this stand in the way of you accepting my answer. .it does not cost you more money and we will still be able to communicate, ,.please understand, i can not see, hear or touch the vehicle and only know what you tell me. Bonuses and positive feedback are appreciated.. if you are not satisfied with my answer, please do not leave bad feed back ,i will gladly opt out and let another expert handle the question. .if i have sent any diagrams, please print them. .sometimes you may need to right click the image [,then save picture as]to save it to your computer so you can open it with your picture program...Please ask if you need more help.
Customer: replied 1 year ago.
So why is the idle jumping up and down though?
Expert:  Tim's Auto Repair replied 1 year ago.
i would think the idle is doing this because of A COUPLE OF THINGS,,
first,check all vacuum hoses/lines for a vacuum leak,but,the common thing for this 5.3 is the iac[idle air control] valve,,this is on the side of the throttle body,sometimes you can just remove and clean the iac with carb cleaner and this will fix the idle
thanks

Related Chevy Questions