How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Gary Your Own Question
Gary
Gary, Chevy Technician
Category: Chevy
Satisfied Customers: 15728
Experience:  15 years GM master tech
19513769
Type Your Chevy Question Here...
Gary is online now
A new question is answered every 9 seconds

2004 Chevy Suburban z71, 4x4, 5.3L engine 265,000 miles. When

Customer Question

2004 Chevy Suburban z71, 4x4, 5.3L engine 265,000 miles. When engine starts cold normal oil pressure, as engine approaches normal operating temp oil pressure drops to 0. At normal operating temp pressure on gauge is 0 and Engine Oil Pressure warning comes. I suspect bad O ring at pick-up tube or oil pressure relief valve stuck open.
Question:
Since it is a 4x4, to drop the oil pan and get to the oil pump, the whole front end has to be disassembled and front axel supported. (around $2000 I have been quoted) There is a 84 year old reputable engine rebuild service hear in Houston that will rebuild the engine for around $2,900.00. What would you do
Submitted: 1 year ago.
Category: Chevy
Expert:  Gary replied 1 year ago.
yes the front diff must be removed to drop down the oil pan on these 4X4 truckswith the oil pressure confirmed 0 with a mechanical oil pressure gauge connected to the engine the issue is definitely inside the enginethe best bet most people go with is to drop the oil pan and measure the bearing clearances and also check and see of the bottom of the pan is filled with sludge or the pike up tube is plugged or restricted and check the pick up O-ring depending off of that would matter to rebuilt it or buy a reman or new engine with a 5 year 50K warrantyif the bearings are bad then rebuild it or replace it if the bearings are good clean the oil pan out and pick up tube and replace the oil pump
Customer: replied 1 year ago.
YOU SUGGEST I PUT A MANUEL OIL GAUGE ON HTE ENGINE TO TEST ACTUAL OIL PRESSURE, IS THERE ANY OTHER PLACE TO HOOK A GUAGE UP OTHER THAN THE OIL PRESSURE SENDING UNIT?
also, DOES THE OIL PRESSURE SENDING UNIT SEND INFO TO THE GAUGE AND THE DASH BOARD LOW OIL PRESSURE ALARM?
Expert:  Gary replied 1 year ago.
yes connect the gauge into where the oil pressure sensor is located on the engine
yes the oil pressure sender ( sensor ) tell the computer the oil pressure then the computers send that information to the gauge cluster
Customer: replied 1 year ago.
OK, got a manual gauge connected in the port where the sending unit connects. 35# ***** pressure at start up 35# ***** full operating temp at idle, 40# ***** at 1000 rpm and above. The sending unit is 1 month old but going to get a new one. If it is not the sending unit, could the problem be in the dash cluster or the Instrument Panel Cluster/Driver Information Center, IPC/DIC, in the fuse block?
Expert:  Gary replied 1 year ago.
it can be a defective sensor or the connector at the oil sender or possibly one of the wires from it to the computer
if you confirmed it never goes to under 10 PSI with the mechanical gauge the odds are the sender is just defective
Customer: replied 1 year ago.
OK, I'll get a new sending unit and see how it goes.Thanks
Larry
Expert:  Gary replied 1 year ago.
anytime
let me know how it goes
you can always get me back through this post anytime for any follow up anytime even after you rate us here at Justanswer !