How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Gary Your Own Question
Gary
Gary, Chevy Technician
Category: Chevy
Satisfied Customers: 15728
Experience:  15 years GM master tech
19513769
Type Your Chevy Question Here...
Gary is online now
A new question is answered every 9 seconds

I have a 2004 Chevy impala 3.8l v6, I been having issues

Customer Question

Hi I have a 2004 Chevy impala 3.8l v6, I been having issues with both the engine cranking but not starting after it warms up and my speedometer stuck at 30mph when it was normal before I let it warm up. When it started it was idling smooth and it sputtered when I accelerated, then reaching temperature it dies and wouldn't start back up. To go back from before all this so you know what Ive done I replaced a bad ignition switch, replaced both fuel pump and filter, a bad fuel regulator, I replaced sparkplugs, I tested the ignition system and replaced what I believe was a bad crank sensor. Cleaned and Tested coil packs, ICM and those were good. I tested the TPS sensor and it was good. I guess next would be the Mass Air but don't know if that would cause that issue.
Submitted: 1 year ago.
Category: Chevy
Expert:  Gary replied 1 year ago.
I am sorry for the long waitare there any codes being set at all ?when it will not start it will physically crank over and just not fire up ?how often will it act up like this ?
Customer: replied 1 year ago.

Has pulled no codes

It cranks just no start

It started acting like this when it broke down on me and I did all those repairs

Expert:  Gary replied 1 year ago.
can you get this to act up and see when cranking it over if you have spark at the spark plug wires and good fuel pressure key ON engine OFF when its not starting ?
Customer: replied 1 year ago.

The first time it acted up I check fuel and got no pressure then I replaced the pump, filter, regulator and then I got good fuel pressure. then the next time it act up I checked spark and got no spark then tested sensors, coil packs, ICM and found that crank sensor was bad, replaced it then i got spark. started up warmed up then died no start again.

Expert:  Gary replied 1 year ago.
ok when it dies the last time did it have spark and fuel pressure ?
Customer: replied 1 year ago.

Has fuel pressure but haven't check for spark again, will check this morning and get back to you

Expert:  Gary replied 1 year ago.
ok let me know
Customer: replied 1 year ago.

thank you but I figured it out

Expert:  Gary replied 1 year ago.
what did you find ?
Customer: replied 1 year ago.

I found out that the engine harness was bad and shorting out the sensors causing it to give me mixed signals when testing

Expert:  Gary replied 1 year ago.

good to hear

im glad its running fine now

Related Chevy Questions