How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Joel Your Own Question
Joel
Joel, Auto technician
Category: Chevy
Satisfied Customers: 1603
Experience:  GM, ASE Certified Technician. Chevy, Buick, Pontiac, Olds. Over 18 Years experience and growing.
5217488
Type Your Chevy Question Here...
Joel is online now
A new question is answered every 9 seconds

95 Lumina rear defroster not working already tried with new

This answer was rated:

'95 Lumina rear defroster not working already tried with new 30a fuse. Pushed in knob where icon says push nothing happen.
Hello and welcome.
Yes, most likely it is because of the temp sticker on the rear glass. When they are removed, it tends to also remove some of the grid lines for the defroster. It can be very hard to see.

If you have a test light i can give you direction on now to find the broken grid line(s). Or, you can just just go in the back seat and look VERY CLOSELY at the lines. Look for a tiny break in one or more of the lines.

If you can see them, you can just get a repair kit from any parts store to fix it yourself. The kit comes with a small paper template, paint and a brush.
Joel and 5 other Chevy Specialists are ready to help you