How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask GM Tech (Cam) Your Own Question
GM Tech (Cam)
GM Tech (Cam), Chevy Technician
Category: Chevy
Satisfied Customers: 29395
Experience:  GM Grand Master Technician 2007. 14 years experience.
Type Your Chevy Question Here...
GM Tech (Cam) is online now
A new question is answered every 9 seconds

2010 chevy: a cold air filter installed a long..coils..warranty

This answer was rated:

I have a 2010 chevy sil 1500 with a 5.3 auto I had long tube headers an a cold air filter installed a long with aEFI live tune 3600miles ago the truck only has 4600miles so I took it to my local chevy dealer service they tried a for a week O the problem is it's missing #3&5&7 cil now they said they swoped coils &injectors and plugs from the other side no change now they did not go to GM in fear of the warranty so I took to a tune shop I had the tune removed and set back to stock so I would do I take back to the dealer or can u help in how to giude them or the dealer what to look for or what to do next. Thanks Tim

GM Tech (Cam) :

Were there no misfires on #1?

9:57 AM

Were there no misfires on #1?

Customer: replied 5 years ago.
None they tell me manly #3 an intermitting 5,7
Ok, does it chatter at all?
Is this a flex fuel engine?
Customer: replied 5 years ago.
No no noise just no power and yes it is a flex fuel motor
OK, did you check the oxygen sensor? Swap both front ones to see if the misfires move to the other side.
Customer: replied 5 years ago.
I'm tring to get the mich on the phone where the truck is now he's out to lunch I'll get back to u
Ok. IF that is not it then have him do a test on the lifters.
Customer: replied 5 years ago.
Ok Ill tell him that also
Customer: replied 5 years ago.
Ok I took my truck to the dealer again an told them to do the o2 thing an the valve check but the tech that worked on it before is not there to day so I told them to call me as soon as hay start working on it so till tomorrow latter thank you
Customer: replied 5 years ago.
Ok I talked to the mich that was out to lunch he said on the last test drive #1misfired 21 times #3 2100 times#5 185times #7 180 times
Do you still have the converters on it? If so, is the drivers side plugged at all?
Customer: replied 5 years ago.
Yes there is cats on it the race or high flow after market how can tell if 1 is clogged up
The test is done with a pressure gauge in place of the front oxygen sensor.
Customer: replied 5 years ago.
Ok I'll let you know when I get to the truck at the dealer tomorrow I'll will keep you up dated as it gos
OK, just so you know, more than 1 psi at any time is too much
Customer: replied 5 years ago.
I just talk to the service writer a the dealer he just told me they change the o2 sender when they had it last time. I told him to check for possible cad converter clogged. I call him back in a hour or so
Ok, let me know
Customer: replied 5 years ago.
Ok I have the the truck at the wrong place first they coundnt find the o2 cent now hay can't find the cats I'm on my way to them I'll let you know when I get there
Customer: replied 5 years ago.
Is it possibility tolkien to u on the phone I'm here with the mich at the dealership my cell(NNN) NNN-NNNN
Sorry I cannot.
They cannot find your o2 sensors?
Customer: replied 5 years ago.
Yes we found them and they have been changed. Werplacedbank one o two sencer
did that fix it?
Customer: replied 5 years ago.
The fuel trim data is all out of whack the mich resets them they go right back out again also the o2 readings post and pre readings are all flucuwating
They will, but does it spend more time rich or lean?
Customer: replied 5 years ago.
Fuel trim stay at -31% both banks
Ok, that means they are running rich, so do you have the tuner turned off?
Customer: replied 5 years ago.
Then something is cauing the system to be running rich. What else did you change?

Customer: replied 5 years ago.
Nothing else was done to the motor that why this is so strange be cause is run like a beast for 3500miles. Now the want to put a PCM in it at 300.00 bbucs
That would be my next guess if the fuel is good, and the sensors are good.
Customer: replied 5 years ago.
Alright so changing the PCM is that going to fix this I mean do PCMs go bad
They can, and that would depend on the diagnosis done to get that far.
Customer: replied 5 years ago.
Well from what Iv tolded you is the right step to do
I think it will, but with out seeing it in person I am only 90% sure.
Customer: replied 5 years ago.
Ok I'll tell them to change it now do think that is under warranty or forget that
Since you chipped it, they may not go for that.
Customer: replied 5 years ago.
They have to order it so it won't be in till Friday sod want to wait till then to see if that fixes it or should I accept answer now
That is up to you, I just ask that you don't forget since you accepting is the only compensation I get for the time I spend with you.
GM Tech (Cam) and 5 other Chevy Specialists are ready to help you
Customer: replied 5 years ago.
Ok I'll hit the accept and take car of you for not only for the help on this truck but on the last one also thank you very much Ill e mail back and let u know the end results
Customer: replied 5 years ago.
the PCM didnt change a thing now what do you think is next
Then they missed something in the wiring or sensors. Are the oxygen sensors the ones the truck came with? Do they have a white coating or any physical damage?
Customer: replied 5 years ago.
now they said they chang the #1 o2 on that side with anew one
but you said they swapped them before?
Customer: replied 5 years ago.
but the told me that they just put anew in in steed of swapping them
If GM was paying then ok, but otherwise swapping is cheaper and the front ones are identical.
Customer: replied 5 years ago.
well they sin there not charging me for that yet!
Ok, let me know the outcome.
Customer: replied 5 years ago.
the out com of what the already put anew one in no change
ok,is there any chance the headers are leaking or causing the flow to be diverted away form the sensor to give it an inaccurate reading?
Customer: replied 5 years ago.
Now there saying it's mas air sensor and the volant cold air system
Do you have the old system to put back in and try?
Customer: replied 5 years ago.
Yes I just found it Im on my way to the dealership now with it
Ok, let me know what you find when you get it in.
Customer: replied 5 years ago.
Do you remember asking me about a chatter noise now its chattering when u let off the gas and yes it still missing
Ok, that now sounds like the common lifter issues.