How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask GM Tech (Cam) Your Own Question
GM Tech (Cam)
GM Tech (Cam), Chevy Technician
Category: Chevy
Satisfied Customers: 29396
Experience:  GM Grand Master Technician 2007. 14 years experience.
Type Your Chevy Question Here...
GM Tech (Cam) is online now
A new question is answered every 9 seconds

2005 Chevrolet Equinox LS: the cruise control..brake pedal..hood

Customer Question

I have a 2005 Chevrolet Equinox LS and have this problem:

The brake lights don't come on when pushed but when I lock the vehicle with the remote then the brake lights come on and the cruise control does not engage even though the little green light on the steering for the cruise control lights up when pushed.

Is there a relay problem? or will it be something else as I have replaced both switches on the brake pedal and I have checked all the fuses inside the car and under the hood
Submitted: 6 years ago.
Category: Chevy
Expert:  GM Tech (Cam) replied 6 years ago.

Greetings and Welcome to Just answer.

Did you check the power at the switch?


Customer: replied 6 years ago.
which switch? there are 2 at the brake pedal
Expert:  GM Tech (Cam) replied 6 years ago.

The one with the red/white and the lught blue wires.


Customer: replied 6 years ago.
again I ask, is this on one of the brake pedal switches? or are you talking about another switch?
Expert:  GM Tech (Cam) replied 6 years ago.

Yes this is one of the brake pedal switches. It is the bottom on. You did get it adjusted properly?


Customer: replied 6 years ago.
Even though I replaced both these switches with new ones and they were adjusted properly, I rechecked the old switches with a meter and found out that they still worked so, the problem is not with the switches and like I said from the start that I am thinking that there is a faulty relay or something else?
Expert:  GM Tech (Cam) replied 6 years ago.

Ok, but is there POWER at the red/white?

I am trying to guide you through some diagnosis.


Customer: replied 6 years ago.

I don't have the car with me its at home so I will have to check tonite and let you know tomorrow.



Expert:  GM Tech (Cam) replied 6 years ago.

You can reply at any time for follow up information regarding this issue, even after you accept my answer and I will reply.

Customer: replied 6 years ago.

Thank you,


Talk to you tomorrow.



Expert:  GM Tech (Cam) replied 6 years ago.

Any updates?


Related Chevy Questions