How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask John Your Own Question
John
John, Master A.S.E Automotive technician
Category: Chevy
Satisfied Customers: 9176
Experience:  A.S.E MasterTechnician A1-A8 w/L1,38 years experience General Motors Master Technician
6408229
Type Your Chevy Question Here...
John is online now
A new question is answered every 9 seconds

rough idle 1989 chevy s10 blazer stalls at red light

Customer Question

rough idle 1989 chevy s10 blazer stalls at red light
Submitted: 6 years ago.
Category: Chevy
Expert:  John replied 6 years ago.

Hello & Welcome to JA,

 

This problem can be a faulty ignition switch ,make sure you are not losing voltage from the switch to the coil & module when this happens.

The problem can also be a faulty ignition coil,module,or distributor pick up coil.All these parts can be tested but if the problem is intermitten it may show good when tested.

Make sure you are not losing fuel pressure when this happens.If it is hard to restart & spraying carb cleaner in the intake will start it for a short period ,you have a fuel pump problem most likely.

John and 6 other Chevy Specialists are ready to help you
Customer: replied 6 years ago.

I replaced the coil and just put this engine in. The old engine was doing the same thing but i thought that it had to much cam. This engine is stock and has the same problem.

I repaced the engine wire harness and did ohm test on every wire on the harness before I put it in have also replaced the ecm. i have no check engine light until it stalls.when i run the codes i get a 33 and no others.I had this engine balanced and blue printed at houston engine and balance.lots of money invested.I went to have state insection and they said to much unburn fuel in the exhast at slow speed but fine at higher speed. PLEASE help.

Carl

Customer: replied 6 years ago.
It starts right back up after stall and runs down the road great plenty of power
Expert:  John replied 6 years ago.
OK,I suggest setting the minimum air rate (idle speed ) & replacing the Idle Air Control valve on the TBI.This is done by blocking the IAC passage at the TBI & setting the idle speed screw to 550 RPM.This condition is also caused by a faulty pick up coil in the distributor.
Customer: replied 6 years ago.
This TBI has the idle screw adj blocked so you cant adj. I just replaced the distributor with a brand new one complete shaft and all. when I look in the air port I can see the IAC move in and out. As the idle gets low and rough the the IAC moves back and the idle increases then it moves back in and the idle gets rough agian.this only happens in gear with brake on or E brake on so I dont think its a bad brake booster.Do you think I should remove the solder and adj the Idle screw. The TBI has new injectors and all new gaskets.When I remove the neg cable and clear the codes the 33 code stays gone unless I let the engine completely stall.
Expert:  John replied 6 years ago.
ALL screws on GM TBI units are factory sealed ,sometimes due to wear,it is necessary to remove the factory plug & adjust.Make sure the TPS voltage is stable (not jumping around) & is around .50MV.
Customer: replied 6 years ago.
I have it set to.51MV and its stable at WOT its 4.70MV I will try this if it works I will pay again thank you very much.
Expert:  John replied 6 years ago.
You are very welcome,have a good day.
Customer: replied 6 years ago.
Right back to the same old thing rough idle and stall.It seemed to idle fine the I test drove it and it was back to the same. Im at wits end.
Expert:  John replied 6 years ago.
look at the fuel trim #s ,they should be 128 in closed loop.Check for vac leaks at the intake manifold.

Related Chevy Questions