How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Greg A Your Own Question
Greg A
Greg A, Master Troubleshooter
Category: Chevy
Satisfied Customers: 7960
Experience:  Working with Electronics & Cars for 25+ Years
Type Your Chevy Question Here...
Greg A is online now
A new question is answered every 9 seconds

2000 Chevy Astro van. Brake and ABS dash light are on. No DTCs

Customer Question

2000 Chevy Astro van. Brake and ABS dash light are on. No DTCs after scanning. How do I reset the lamps?
Submitted: 7 years ago.
Category: Chevy
Expert:  Greg A replied 7 years ago.

Hello & Welcome,


May I ask what scan tool you are using?



Customer: replied 7 years ago.
My Scan tool is a MasterTech
Expert:  Greg A replied 7 years ago.

OK, thanks.


Do you have a plug-in module that is capable of reading the GM ABS system? Most scan tools do not have the capability to do this without an extra module.



Customer: replied 7 years ago.
This is a high end ($4000) scan tool, but I am not familiar with all of the modules for it yet. Do you know what I need to look for?
Customer: replied 7 years ago.
Ok, I found a module that says to use it with Tech 1A when performing checks of the ABS, ECM, and body system diagnostics. It has a toggle switch on the side indicating 2 positions, SDL 2 and E&C bus.
Expert:  Greg A replied 7 years ago.

I am not really familiar with that particular brand of scanner myself.


Unless you have low brake fluid, what usually happens is one of the wheel speed sensors, or the wiring to them, has trouble.


I have a description of the system below (as a PDF file) and the schematics for the system.


ABS Description






You could check the wiring harnesses going to the sensors and see if there is anything obvious, like pulled wires or dirty connections.


Please let me know what you find or if you need more information.


Thanks, XXXXX

Greg A and other Chevy Specialists are ready to help you
Customer: replied 7 years ago.
Ok..I cleaned the wheel speed sensors and the wheel stator, I will try and figure out how to use the module I found. If I can't, I guess I will email again. thanks.
Expert:  Greg A replied 7 years ago.
You are quite welcome.

Related Chevy Questions