How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Mazda Ed Your Own Question
Mazda Ed
Mazda Ed, Auto Service Technician
Category: Chevy
Satisfied Customers: 2223
Experience:  ASE Master Technician, Mazda Master Technician, GM and Ford factory trained. 15 years experience.
5624692
Type Your Chevy Question Here...
Mazda Ed is online now
A new question is answered every 9 seconds

1998 Chevy Blazer: the 4WD wont engage..vacuum line..whats wrong

Customer Question

Hello, I have a 1998 Chevy Blazer, and the 4WD won't engage. My boyfriend has a blazer and so does my neighbor and they both have had same problem. My neighbors problem was solved by getting a new vacuum line, but that isn't whats wrong with mine. Is this something that is really common with Blazers? And if so, what else could it be? (By the way, we just realized that my 4 low DOES engage, but when we push the 4 high button it blinks and then goes back to 2 high). I hope you can help! You were extremely helpful before! Thank you!
Submitted: 8 years ago.
Category: Chevy
Expert:  Mazda Ed replied 8 years ago.

HiCustomer

I just got done helping another customer a couple of days ago with the same exact problem. Since you removed the battery, the module should have already reset. If for some reason it did not, then remove the connectors from the TCCM. It is located behind the kick panel on the passenger side. Check the connectors for signs of water. If your boyfriends blazer has the same TCCM then you can try swapping his in temporarily. If it is different, then reconnect the TCCM after several minutes and try all mode shifts. Let me know which shifts are working and which are not.

2HI -> 4HI

4HI -> 4LO

2HI -> 4LO

4LO -> 2HI

4LO -> 4HI

4HI -> 2HI

Customer: replied 8 years ago.
Hi, I did receive your answer, but haven't yet been able to try your suggestion. It has been raining really badly here. I promise to get back to you just as soon as I can work outside. Thanks so much. Jess
Customer: replied 8 years ago.
ON MY BOYFRIEND'S 1995 CHEVY S-10 BLAZER THE 4WD HIGH LIGHT STAYS ON BUT NO 4WD. 4WD LOW WORKS PERFECTLY, IS THERE TWO DIFFERENT VACUUM LINES THAT GO TO THE TRANSFER CASE SERVO.
Expert:  Mazda Ed replied 8 years ago.
The 95 uses a different system than the 98 so that won't help you out. Let me know when you do the testing from above.

Related Chevy Questions