How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Roy Your Own Question
Roy
Roy, import/domestic specialest
Category: Car
Satisfied Customers: 5589
Experience:  ASE master tech for 40 years
3506196
Type Your Car Question Here...
Roy is online now
A new question is answered every 9 seconds

Ac not cold, Yes replaced compressor, expansion valve and

This answer was rated:

Ac not cold
JA: Have you checked the Freon level?
Customer: Yes replaced compressor, expansion valve and receiver dryer
JA: What is the make/model/year of your car?
Customer: 2008 Suzuki forenza
JA: Are you fixing your Forenza yourself? What have you tried so far?
Customer: Hoses get cold but the evaporator core doesn't. Low side pressure 30 highside 120
JA: Anything else you want the mechanic to know before I connect you?
Customer: I think that's all

Hi, My name is Jay

If you are on high blower speed then you have not put in enough freon. Your high side should be close to 190 or 200 psi and low side will be between 35 and 45 on high blower speed and then pressures should be 25 to 30 on low and 180 on high side.

Try adding about 4 oz of freon and retest pressures and temperature on medium blower with a/c on max air.

Customer: replied 7 days ago.
I have an ac machine the freon amount for the system is 1.47 lbs. I know that the freon amount is good

I have seen where the machines are not putting in correct amount. If you try and add a little freon and pressures do not go to normal then the compressor is not pumping enough pressure. Try to raise the rpms to see if high pressure goes up close to 200?

If the lines are getting cold like you said but evaporator is not then there is not enough freon to flood the evaporator.

Customer: replied 7 days ago.
I added + 4oz low side goes to 20psi shuts down ac compressor high goes to 300

Now we are talking about getting pressures. The compressor is good but the system should be shut down to see if it equalizes. If it does not then the expansion valve is stuck.

Before when you had 120 and 30 it was stuck one direction and now its stuck in the other. Remove the 4 oz freon and then retest before condemning the expansion valve. It may have just been stuck from new and adding extra freon caused it to unstick.

Customer: replied 7 days ago.
The ac was working fine then the ac compressor started making noise after a few weeks it stopped​ cooling. I replaced the compressor, expansion valve and receiver dryer I flushed the evaporator core and condensor. Wouldn't cool, low at 30 high at 100
Customer: replied 7 days ago.
I got another compressor and expansion valve and reciver dryer I flushed the system again and I still get 30 low and 120 high

Did you put enough oil back in for the items you flushed? About 1 oz oil for each part flushed? Also it still sounds like the expansion valve is stuck.

Signing off for a few hours for Fathers day with family. Will be back on in a few hours.

Customer: replied 7 days ago.
I touch the smaller hose coming out from the expansion valve and it's really cold. Can the evaporator core be plugged?

do you still need help???

Roy

Customer: replied 7 days ago.

ok, I read your posts and responses.

what are the pressures now when running???

Roy

Customer: replied 7 days ago.
30 low high 120

what is the outside temp???

Customer: replied 7 days ago.
98

ok, your high side is way off.

normal high side is 2 times outside temp plus 15%.

your low side is good.

how does the dryer feel with the ac running

Customer: replied 7 days ago.
Warm

ok, thats good.

from your readings, you have a bad compressor. does the high side needle stay solid or does it fluctuate??

Customer: replied 7 days ago.
Stays solid, I already replace that compressor twice

that low side reading shows 50 lbs?????? you told me it was 30?????

Customer: replied 7 days ago.
The car was off when I took that picture, should t the system equalize?

you never said that.

yes, the expansion valve is bad. that needs to be replaced.

Roy

Customer: replied 7 days ago.
I already replaced it twice also, I can replace it again it will take me 20 mins. But I don't think that is the problem

if the system does not equalize, the valve is bad.

it better take you longer than 20 minutes. you need to vacuum for at least 30 munites plus the removal and repair.

Roy

Customer: replied 7 days ago.
What I found on the expansion valve

materiel from the old dryer.

Customer: replied 7 days ago.
I flushed everything twice already, what do you recommend I do? Replace everything again including evaporator core and condensor?

flushing is not recommended

use air from a blow tip. even though you replace all those components, there still may have been some in the lines.

Roy

Customer: replied 7 days ago.
I am going to blow everything out and replace the expansion valve . See what happens won't be able to get evaporator and condensor till Tuesday and it's like 110 degrees here. I appreciate your help will let you know how it goes. Thanks again.

your welcome

Roy

please take a moment and rate my service. please hit 5 stars so the site will pay me for my efforts. it is the only way we get paid for our efforts.

Roy

Customer: replied 7 days ago.
Inside the cabin 68 degrees
Customer: replied 7 days ago.
Why is the low side at 20 shouldn't it be higher?
Customer: replied 7 days ago.
Out side is 107

yes, did you replace the expansion valve or just clean it???

did you vacuum for 20 minutes to get the moisture out of the system???

68 is right for the temp, should be about 30% difference to ambient temp

is the evap sweating???

Roy

Customer: replied 7 days ago.
I replaced it, I had a new expasion valve an receiver dryer. I did vacuum for 20 mins and no I don't see any condensation

spray some cold water from a garden hose on the condenser and see if the low pressure changes

Customer: replied 7 days ago.
I turn off car and again it won't stabilize​ low 60 and High110 I need to remove expansion valve again see what I find. I am a diesel mechanic I don't know about a/c systems just the basics, so please bear with me.

no worries. you still have debris in the system

Customer: replied 7 days ago.
I took the expasion valve off again It was clean as a whistle. I recharge the system again and I got 20 psi on the low and 125 on the high. I add 2onz of freon more the low went to 25 and the high to 225 inside cabin 56 degrees out 105
Customer: replied 7 days ago.
It's cold but I don't like it low side is too low and high was to low. Something is not right and it will damage the compressor. I will replace everything on Tuesday except evaporator core (need to remove dash) . New condensor new expansion valve new dryer and a new compressor. See what happens hate to trow parts at a vehicle to fix it.

I hear you

Roy

please take a moment and rate my service. please hit 5 stars so the site will pay me for my efforts. it is the only way we get paid for our efforts.

Roy

Roy, import/domestic specialest
Category: Car
Satisfied Customers: 5589
Experience: ASE master tech for 40 years
Roy and 3 other Car Specialists are ready to help you
Customer: replied 7 days ago.
system won't stabilize low 65 high 110 even after 5 mins off.

yep, expansion valve again.

thank you