How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Merc320 Your Own Question
Merc320
Merc320, Technician
Category: Car
Satisfied Customers: 193
Experience:  City & guilds pt 1 & 2
22484842
Type Your Car Question Here...
Merc320 is online now
A new question is answered every 9 seconds

I have a 2006 Nissan Altima 2.5 4 cylinder. It is

This answer was rated:

I have a 2006 Nissan Altima 2.5 4 cylinder. It is overheating. There are no coolant leaks. I have changed the water pump, and it solved the problem for a couple days then it started overheating again. Still no coolant loss. To take them out of the equation, I removed both thermostats. I have a pair of new thermostats to install after I solve the overheating problem, but for now I just took them out of the equation and I changed the the coolant temp sensor. Thinking I may have gotten a defective water pump I changed it again, I make sure I bleed the air out when ever I refill the coolant. Well it still does the same thing. The fans kick in at about 210 degrees, but the temperature keeps on climbing. The car is acting like there is no coolant circulation but I have eliminated what I know of that affects it, so I am stumped. What do I do now?
Customer: replied 5 days ago.
One more thing, even though the temp is like 240 degrees, when I turn the heater on it is only warm not hot.
Customer: replied 5 days ago.
Also when I look into the radiator while the car is running, I see no water movement.

Hi

You may have two issues here. Both the radiator and heater matrix ,one or both may well be blocked not giving you circulation.

With no thermostat fitted then you should see water flow looking in the radiator.

Customer: replied 5 days ago.
The radiator cant be blocked, Squeezing either upper or lower hose will create movement in the radiator. I am thinking the heater circuit could be blocked, due to the lack of heat coming from the heater, but would a blocked heater circuit block the entire heating circuit? Also there is very little water movement in the radiator with the car running, even with no thermostats, what little there is to me seems due to movement of of heated water from the block not from water pump pressure.
Customer: replied 5 days ago.
It's 11 at night here, I'm in my jammies, and don't plan on dealing with my car till tomorrow. So no need to call. It did come on suddenly like I said earlier, I changed my water pump, it did the trick for a couple days, then started over heating again, even worse then before I changed it.

Hi

The heater cant cause overheating but the radiator can.

You will get movement of water in rad when squeezing you are only moving the upper part.

When the engine is hot run youre hand all over the radiator should be hot all over.

Customer: replied 5 days ago.
There is movement when I squeeze the bottom hose also. If there were any movement between the top and bottom hoses though, out of the block one end and back in the other, there should be some reaction when the fans kick in, there is none, temperature just keeps on rising. Could there be a blockage in the block big enough to stop water flow via the van impeller? It so acts like the water pump doesn't work but I don't think I would get a defective pump twice in a row, so I am sure the water pump is working. I'll just get a new radiator if I know the block is unlikely to be blocked. With the lack of thermostats, is there anything else that could be plugged up inside the engine that would cause this?

Hi

With thermostat out bleed is not reguired.

I am still gunning for radiator.

Merc320 and other Car Specialists are ready to help you
Customer: replied 5 days ago.
OK, I'll focus on the radiator. Thanks

Glad i have helped you.

Customer: replied 3 days ago.
You were right. I took your advice and replaced the radiator, but before I did I tested it by disconnecting the bottom and top hose at the engine the raising the end of the bottom hose up even with the top of the radiator then I filled water in through the open end of the top hose. Sure enough the top hose backed up with water and a couple of seconds later water started dribbling out of the bottom hose, telling me the radiator was at least partially plugged. Replacing the radiator did solve the overheating problem.

fantastic news.

Please rate me.