How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris (aka-Moose) Your Own Question
Chris (aka-Moose)
Chris (aka-Moose), Technician
Category: Car
Satisfied Customers: 1080
Experience:  16 years of experience
2499435
Type Your Car Question Here...
Chris (aka-Moose) is online now
A new question is answered every 9 seconds

2004 suzuki forenza new feul pump assembly,new coil,new

Customer Question

2004 suzuki forenza new feul pump assembly,new coil,new crank shaft positioning sensor still wont start
Submitted: 1 month ago.
Category: Car
Expert:  Jerry replied 1 month ago.

Hello and welcome. My name is ***** ***** you for visiting the site, I am reviewing your question and will reply shortly, thanks.

Expert:  Jerry replied 1 month ago.

Do you hear the fuel pump come on for 2 seconds when the key is first turned on?

.

Do you know what the fuel pressure is??

.

Have you checked for spark at the plugs?

.

Does the engine have good compression?

Customer: replied 1 month ago.
I hear the fule pump when i turn on the ignition key
I hear onther kind of pressur when I krank ( when it start the ingine,but now it dose not,wont start)
spark is good
new pump is goog
Expert:  Jerry replied 1 month ago.

I see, thanks.

"Does the engine have good compression?"

Customer: replied 1 month ago.
Expert:  Jerry replied 1 month ago.

Is the timing belt on the mark?

Do the injectors have a pulse to ground when cranking?

Customer: replied 1 month ago.
this qustion is not clear. I unpuged the injector connector,clean and put it back
Expert:  Jerry replied 1 month ago.

I see, thanks. Do you know if it will start for a second or so with a shot of ether? Just to see if it is a fuel problem.

Expert:  Jerry replied 1 month ago.

Also, what were the compression readings in the cylinders?

Customer: replied 1 month ago.
I do not have now. It was in the shop, all readings were positive, some times it start and runs perfect then changed crank shaft positioning sensor,but the problem is still there
Expert:  Jerry replied 1 month ago.

I will opt out and open it back up. Please DON’T REPLY to this post as that will lock the question back to me, also DON’T RATE THE ANSWER yet, someone should be along shortly, I’m sure, thanks and sorry I wasn’t able to help with it.

Related Car Questions