How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Technician
Category: Car
Satisfied Customers: 27591
Experience:  17 years automotive training and experience.
14928985
Type Your Car Question Here...
Pete is online now
A new question is answered every 9 seconds

I drive a 2007 range rover sports, the screen and radio wey

Customer Question

Hello
JA: Hi. How can we help?
Customer: I drive a 2007 range rover sports, the screen and radio wey frozen, i remove the battery terminals and now the screen and radio are totally blank and non functional
JA: Have you tested the battery with a voltmeter? And can you see if it's leaking or not?
Customer: i have this portable battery jumpstart i used it with it to see if i could add addtional power to it.. still didnt work
JA: Are you fixing your Range Rover yourself? What have you tried so far?
Customer: nope i am not, i jus remove the battery terminals thats all i did, basically all i can do is that and maybe check the fuses
JA: Anything else you want the mechanic to know before I connect you?
Customer: thats basically my problem, and am not happy when my car isnt functioning properly
Submitted: 8 months ago.
Category: Car
Customer: replied 8 months ago.
hello
Expert:  Pete replied 8 months ago.

My name is ***** ***** I am a professional here at Just Answer. I noticed that your question had not received a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.

It sounds like the fuses are all o.k. since the screen and radio were on at first but frozen and it sounds like you had done the correct reset that most will do to try and correct this which did not work here.I do not suspect this is a fuse or loss of power or ground issue since they were frozen at first and now do not work at all.This sounds like a fault with the radio assembly itself.I have seen several of these fail/act up before in the past needing replaced for this issue here.I would have the powers and grounds tested at the radio to verify this as well as the fault codes checked/read out with a fully compatible scan tool to see if for sure this is the cause here.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service,your 5 star rating is appreciated.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete