How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris (aka-Moose) Your Own Question
Chris (aka-Moose)
Chris (aka-Moose), Technician
Category: Car
Satisfied Customers: 1080
Experience:  16 years of experience
2499435
Type Your Car Question Here...
Chris (aka-Moose) is online now
A new question is answered every 9 seconds

I have changed both fuel pumps and fuel filter. Tried a

Customer Question

I have changed both fuel pumps and fuel filter. Tried a start and had stil the same problem. Main fuel pump does not run, and the engine died after a feew seconds. Tried too disconnect the regulator, and the the main pump started and the car was running normally. Tried too change the fuel regulator but it did not help.It seems that the relay for the main pump does not gett a start signal from the computer. I can force the relay and the pump starts.
Submitted: 1 month ago.
Category: Car
Expert:  Wolfgang replied 1 month ago.

Thanks for choosing Just Answer . I'm Wolfgang here to help!!

I am confident we can resolve your problem together. Please
understand that I don't know your skill level. In most cases when you have a problem
with the way the vehicle performs, specialized tooling is required to acquire computer
data/information or engine testing results. We didn’t build these complicated vehicles; we
just diagnose and fix them. Also understand that I can't see, smell, hear, or touch the
vehicle either, so it may take a few replies to get to satisfactory results.

Note there may be an issue where the complexity of the issue will require a Premium Service. This service will be an addition to the normal question cost. Usually it does not come down to this but keep in mind!!

I am also going to direct you with the fastest, easiest and most common things to check first. Please be patient and permit me to do what I do best.
I also try to give all of the information you may need, expecting a “positive rating” in
return. I will also continue assisting you after you have rated me, if necessary. If there
is any reason I cannot get a positive rating, please let me know why “in advance”, so I
can go another direction for you. I am sorry you’re having this problem; I’ll help you
through it.
Below is my first answer or request for more information. If you do not understand it, or you need more information from me, or need me to go in more detail.

i do need some more information.

is the cowl area where the wipers and ecu at retaining water ? This is a common issue that needs to be addressed first .

do you you have a VOLT/Ohm meter to test wiring ?

any recent accidents?

thanks

Customer: replied 1 month ago.
Hello
Hwat do you mean whit retaining water.Yes i do have a voltmeter.
Expert:  Wolfgang replied 1 month ago.

in the cowl area where the ecu and wiper motor there are 2 drains that likes to collect debris and clog up the drains . so that is why i have asked that question . and may have flooded the area with the relay box causing all kinds of issues you have!!

Customer: replied 1 month ago.
The drains are open
Expert:  Wolfgang replied 1 month ago.

ok the fuel pimp relay that you activating by hand which one to make sure . picture please!!

thanks

Customer: replied 1 month ago.
It is fpr sure the fuel pump relay, one for each pump. I hawe alsow locked at the diagram. I just plcased a jumper over the contact for this relay, and the pump started.I dont hawe the possibility too picture. What signal too the comp. is actiwating the pump?
Customer: replied 1 month ago.
Is the regulator just a fuel cut off, or is it regulating the pressure by switcing on/off?
Expert:  Wolfgang replied 1 month ago.

due to the design of the fuel tank one side is larger than the other side . so transfer of fuel is needed to get from one side to the other. so there is the main pump and the transfer pump . when cranking both pumps should run and car started the transfer pump will run for about 20-30 seconds and then the main pump only runs .

so i do need to know which relay you are triggering to make the vehicle run ?

i was hoping you can take a picture of the water box fuse/relay panel and post here so i can have look too!!

thanks

Customer: replied 1 month ago.
It is the relay in front off the box. I have now connected a wire from the ignition to the coil off the fuel pump reelay . This means that the fuel pump start as soon the kee i turned. The car runs now as normal, on the right pump (main pump, fuse 14).I can now use the car, but the main pump stays running all the time. I suppose that will do no harm.
Expert:  Wolfgang replied 1 month ago.

got to get this fixed correctly!!!

do you have power of the terminal that has red wire (thinner of the 2) in that relay cavity?

if so then ypu need to to a resistance check from green/red of the relay to pin 65 of the A connector (larger)

let me know