How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris (aka-Moose) Your Own Question
Chris (aka-Moose)
Chris (aka-Moose), Technician
Category: Car
Satisfied Customers: 43872
Experience:  16 years of experience
Type Your Car Question Here...
Chris (aka-Moose) is online now
A new question is answered every 9 seconds

I have a 2002 Land Rover Freelander 2.5 v6 and it keeps

Customer Question

Hello. Hi everyone...
I have a 2002 Land Rover Freelander 2.5 v6 and it keeps going dead. With a hot battery I can drive for atleast an hour with no problem as long as I dont use the lights or the A/C. If I do the transmission will stop changing out, all the dash lights will come on(SRS, ABS, Battery light, TC light) then I will have to press the petal much harder in order to get the car to move forward. Then the dash will start flashing F4. If I continue to drive with this flashing, eventually all the lights will cut off and the needles will stop working(basically the dash just stops working completly). I replaced the battery and alternator even though Autozone said they both were good. Still have the same problem. I even can take the battery poses off while the truck is running and it wont cut off. To see if the alternator was charging, i took out the hot battery while it was running and put in a REALLY dead battery and it charged it. I crunk it up and switched it off a few times with no problems. Then as soon as I tried to go down the street F4 and the other lights popped on and I barely made it back to my drive way. Once again the dash completely cut off and the car went dead sitting in the drive way and wouldn't crank up again. It was about to rain so I tried to let the windows up and everytime I pushed the buttons the car was making clicking sounds. I also have replace the battery 150 AMG fuse and tested other fuses to make sure they were getting power, and they were. The only thing I see that could possibly be the problem is a very small fuse box coming from the wire on the positive terminal with about 3 fuses in it.(they are definitely getting no power) Connected to it is another box about the same size with a yellow relay in it.(witch is definitely getting power) The wires are running from the positive battery pose to these two boxes. Then from the boxes to somewhere inside the truck. Tried to follow them but couldn't....PLEASE HELP. idk whats going on.
Submitted: 2 months ago.
Category: Car
Expert:  Chris (aka-Moose) replied 2 months ago.

Welcome, I'm Chris (aka Moose) I prefer to work when others don't, I am here around lunch and after dinner till after midnight.

Do you own a volt meter so we can diagnose this?

What is the battery min and max voltage at idle to 2500 rpm?

Same test again this time with the headlights, blower, and wipers on?

Expert:  Chris (aka-Moose) replied 2 months ago.

Hello again Chris here,

  • I am following up with you to see if you got everything you needed from my answer. We're you pleased with my help?
  • If you were not pleased with my help, please let me know by replying so I can help more.
  • This post is coming up on the 7 day mark where it times out. When a post times out, that means it's no longer on my active list (you reply and I may never know it.)

Thanks Chris

Related Car Questions