How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris (aka-Moose) Your Own Question
Chris (aka-Moose)
Chris (aka-Moose), Technician
Category: Car
Satisfied Customers: 43905
Experience:  16 years of experience
Type Your Car Question Here...
Chris (aka-Moose) is online now
A new question is answered every 9 seconds

03 Suzuki Carry, 3 cylinder Mitsubishi. I'm looking at it

Customer Question

03 Suzuki Carry, 3 cylinder Mitsubishi.
I'm looking at it for my nieghbor, I do side jobs in my own garage here at home so I have some resources as far as tools and all.
he said he was driving it across a field and the engine light came on, ran fine for approximately 5 to 10 minutes to his house, shut it off and it would'nt start the next morning. He hauled it to me, I found that a limb had punctured the radiator hose, I repaired that, filled it back up with coolant, it's a crank no start but will hit a couple of times like its out of gas, fuel is good, 180 lbs of compression on all 3, I have injector pulse, good spark, spraying starting fluid in the intake makes no change, theres a marking for 5 degrees on the timing and thats exactly where it lands for TDC.
CEL is illuminated & I have a Solus Ultra but theres no selection in my scanner for it, my universal OBD2 reader says no communication... all fuses are good.
Thanks in advance!
Submitted: 3 months ago.
Category: Car
Expert:  Chris (aka-Moose) replied 3 months ago.

Welcome, I'm Chris (aka Moose) I prefer working afternoon till just after midnight.

Finishing up my work day here. I have worked my way down he list top to bottom helping all I can. I think I can help you but I see you have waited a long time. Do you still want or need help?

Customer: replied 3 months ago.
it's still not diagnosed, I've exhausted most all of my resources. The fuel seemed to have a slow burn & smelled old so I pumped out all that was in the tank, put fresh in, installed new plugs & it made no difference at all. I have 45 lbs of pressure as well...
Expert:  Chris (aka-Moose) replied 3 months ago.

Since you have compression, spark, fuel pressure, and fuel pressure. That means there is either no air getting into the engine or the computer is flooding the engine from a computer or MAF/MAP sensor failure. Are the plugs soaked with fuel? If you unplug the injectors can you then get it to run briefly at wide open throttle with starting fluid?

If you're confused on what to do now or later. You have already been charged the full question value. It's now time to compensate the tech that helped you. The only way I can continue to work here and help customers is by getting rated. If you're not pleased yet or plan not to rate me. Let me know so I can help more, close the post, or opt out. Please let me know if you're pleased with my help.

Thanks Moose.

Customer: replied 3 months ago.
Ok, plugs were damp but not soaked, injectors unhooked & spraying starting fluid at wide open throttle makes no change, never hit at all off of it...
Expert:  Chris (aka-Moose) replied 3 months ago.

Are you sure you have good spark and you got 180 psi compression on each cylinder?

Customer: replied 3 months ago.
I've watched the spark several times, it's a hot spark across all 3, I'll double check compression this evening.
It's making no sense to me lol..
Expert:  Chris (aka-Moose) replied 3 months ago.

When substituting fuel all you need is compression and spark.

Customer: replied 3 months ago.
That's what's puzzling here..
I have between 165 to 180 on all 3 cylinders.
Spark looks good, but there was leftover unburnt starting fluid on the plugs, it has C.O.P.s in it, I don't see a crank sensor unless it's behind the timing cover, I do see the cam sensor... what's the possibility of it being bad?
Do you have access to the values for testing it?
Customer: replied 3 months ago.
Engine is the K6A
Expert:  Chris (aka-Moose) replied 3 months ago.

I think I have done all I can. I am going to opt out and let another try.

Related Car Questions