How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Ted G. Your Own Question
Ted G.
Ted G., ASE Certified Technician
Category: Car
Satisfied Customers: 6089
Experience:  20 years auto repair experience, ASE Master Tech, Mechanical Failure consultant, Expert Witness
7183013
Type Your Car Question Here...
Ted G. is online now
A new question is answered every 9 seconds

Last June, the alternator, starter, and battery was

Customer Question

Last June, the alternator, starter, and battery was replaced. I was basically having the same issue about dead battery the next day. A repair shop told me the instrument panel was the problem. I read some forums and found out about instrument cluster causing this. The shop wasn't able to get me one until they could order it beginning of the week. They took it out and I resoldered all the connections that looked cold. They installed in back in and haven't had any issues since June 2015. Now, a auto shop fails the 4.86 Amp draw. Could these be related? Can I pull the connector on the instrument cluster and see if the ampmeter shows normal to rule it out?
Thanks,
Chad
Submitted: 8 months ago.
Category: Car
Expert:  Ted G. replied 8 months ago.

Yes, that would be one way to check it. Or you could try pulling the INST fuse first, and see if it drops out that way. If it doesn't drop then you could go to the cluster connector, if it does then your cluster is acting up again.

Expert:  Ted G. replied 8 months ago.

Yes, that would be one way to check it. Or you could try pulling the INST fuse and see if it drops that way. If it doesn't drop then you could go to the cluster connector, if it does then you know the cluster is acting up again.

Expert:  Ted G. replied 8 months ago.

..