How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris (aka-Moose) Your Own Question
Chris (aka-Moose)
Chris (aka-Moose), Technician
Category: Car
Satisfied Customers: 43896
Experience:  16 years of experience
Type Your Car Question Here...
Chris (aka-Moose) is online now
A new question is answered every 9 seconds

I have a 2000 Land Rover Discoveryii, my M S and gear

Customer Question

I have a 2000 Land Rover Discoveryii, my M S and gear selector would flash, I could shut off the truck and restart it and it would be good! Then it started to do it all the time so I looked up the code and it said the Crank Sensor was bad, I changed it and now it won't start!
JA: Are you hoping to fix this yourself?
Customer: Yes
JA: Great! What have you tried so far?
Customer: Crank shaft sensor
JA: Is there anything else the Mechanic should be aware of about your Land Rover?
Customer: No
JA: I'm sending you to a secure page on JustAnswer so you can place the $5 fully refundable deposit now. While you're filling out that form, I'll tell the Mechanic about your situation and connect you two.
Submitted: 7 months ago.
Category: Car
Expert:  Chris (aka-Moose) replied 7 months ago.

Welcome, I'm Chris (aka Moose). Experts aren't employees / agents of Just Answer. We are independent service providers using the Site to sell their Expert knowledge to Customers. I strive to provide EXCELLENT 5 STAR service, let me know what's needed from me so your pleased.


Try your old CKP sensor. You may have got a bad sensor. Also check the wiring to the sensor and the connector to see if its damaged. If there is no ignition spark occurring then its for a sure a concern at the CKP sensor we need to find.


Thanks for asking your question and letting me try to help you.

If your confused on why or how to rate me, let me know.

I'm only paid from the deposit you've made when you rate 3,4, or 5 stars.

Follow up/Reply as many times as needed before or after rating.

Customer: replied 7 months ago.
I put the old one back in and it just cranks and won't start!! I looked at the wiring and it looks good! When I go to state it the M and S flashes and the battery light is on, what could this mean?
Customer: replied 7 months ago.
Could it be my ECM?
Expert:  Chris (aka-Moose) replied 7 months ago.

I would need to know what trouble codes are stored to confirm the ECM is bad.

Are you getting ignition spark while cranking?

Do you have a scan tool to see if the ECM is getting a CKP signal while cranking?

Expert:  Chris (aka-Moose) replied 7 months ago.

Hello again Chris here,

1) When customers come to Just Answer the website and the experts want them to have a great 5 star experience.

2) We also want them to be so pleased that they come back for future needs.

3) I have the feeling you were not pleased with my help and or need me to help more. If so please do reply.

4) I have an option to upload diagrams, repair guides, find a repair facility, or call you if that would help.

Thanks Chris

Related Car Questions