How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Reggie Whiddon Your Own Question
Reggie Whiddon
Reggie Whiddon, Auto Mechanic
Category: Car
Satisfied Customers: 110
Experience:  Lead tech at river regions auto
90546729
Type Your Car Question Here...
Reggie Whiddon is online now
A new question is answered every 9 seconds

I have a 2010 Escalade and past two years we have had

Customer Question

I have a 2010 Escalade and for the past two years we have had problems with the stabilitrak coming on and causing the car to lose power. We have had it to the dealer and they tell us they can't find anything wrong with it. That is bs because there is obviously something wrong with it. It almost caused us to get rear ended on the interstate and just yesterday it happened again to my wife. When she made her way to the shoulder she slid off the road causing her to hit a pole. Can you please tell me how to get this fixed?
Submitted: 10 months ago.
Category: Car
Expert:  Reggie Whiddon replied 10 months ago.

Good morning I am Reggie and will do my very best to help you. When this happens do any other lights come on other than stabilitrak? When you say lose power does it slow to a certain speed no matter your throttle response? I would describe it as like your gas cable come loose and it hung the throttle open barely above idle your speed would be 35mph or so and mashing the gas does nothing? Am I right?

Expert:  Reggie Whiddon replied 10 months ago.

If so tell me what you do to get the car going again, do you shut it off and restart fine?

Customer: replied 10 months ago.
The service engine light comes on and a message comes across saying engine power is reduced.
Customer: replied 10 months ago.
Shut the engine off for 15-20 sec and it seems to be fine for awhile. Sometimes it does it every 20-30 miles and others its good for hundreds of miles.
Expert:  Reggie Whiddon replied 10 months ago.

Okay i believe i know where your problem may be, at the dealership are they saying they find no codes i dont understand how they could tell you there is no problem. If the light came one it would have set a code and left a recorded piece of data when the problem occured. What are they saying in regards ***** *****

Customer: replied 10 months ago.
I paid you to tell me your opinion not for you to keep asking me questions.
Expert:  Reggie Whiddon replied 10 months ago.

On a vehicle like yours i see alot of throttle bodies or acclerator pedal problems, the electonic drive by wire system is composed of the throttle body, and your gas pedal, there are sensors in each that record position actually two sets of sensors that work opposing to each other if the computer sees a minor glitch in any of these sensors it goes into limp mode which you describe perfectly

Expert:  Reggie Whiddon replied 10 months ago.

Very well sir my opinion is that you have a problem in your electronic drive by wire system that is causing your vehicle to go into limp mode and that fact that you restart it with no problems goes to further strengthen this opinion. This opinion is based off comparisons to pattern failure records and your description of the problem

Customer: replied 10 months ago.
Thank you. I have found other people say the throttle body. It is going back to the dealer tomorrow.
Expert:  Reggie Whiddon replied 10 months ago.

Thank you sir may i assist you any further

Expert:  Reggie Whiddon replied 10 months ago.

Sir have we resolved this, or can i help you further

Related Car Questions