How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Mike V. Your Own Question
Mike V.
Mike V., Auto Service Technician
Category: Car
Satisfied Customers: 23827
Experience:  25 years of experience, Certified Subaru Technician and Nissan factory trained.
2921078
Type Your Car Question Here...
Mike V. is online now
A new question is answered every 9 seconds

2008 altima 2.5 missfire on cy 3 no signal from pcm,replaced with a used pcm,reprogramed s

Customer Question

2008 altima 2.5 missfire on cy 3 no signal from pcm,replaced with a used pcm,reprogramed start runs but slight misfire on 3 ground at tranny good.no vacume leaks,compression good.have you seen this before?i am ase tech,45 yrs
Submitted: 1 year ago.
Category: Car
Expert:  Mike V. replied 1 year ago.
Hi there,I suggest a leak down test. If there is even the slightest buildup on the valves from the smallest amount of carbon it will feel rough. If the leakdown doesn't show carbon then I would consider an issue with the injector. Some good top end cleaner light Seafoam might resolve the issue. Since it wasn't firing on 3 something simple like this could be the issue and it must be pretty small if you are not getting any code for #3What happens next:Just Answer will now charge you for the full amount of your question.My goal is to provide you with 5-star service. If you cannot rate me at least 3-5 stars, we will keep working on this.Just Answer does not compensate me for my time and effort; you do with a 3-5 star rating.Follow up questions are included in your question price even after rating.
Customer: replied 1 year ago.
Mike,i am getting a cyl.3 missfire code
Expert:  Mike V. replied 1 year ago.
I see,Try this, do a pressure test on the cooling system. Let it sit for at least one hour, then remove the plug and see if there is any coolant on top of the piston. Very common head gasket issues on these and usually cause #3 misfire. This particular leak doesn't put any coolant into the oil, just leaks it onto the piston. Causes the fuel mix to be wrong because of course coolant doesn't burn. Usually this is the cause when they first start spitting out that code and I will admit it usually happens after a cold soak, but doing the pressure test speeds up the process. You have to let it sit at least an hour under pressure.Let me know. Stepping out for a bit, but I will be back in an hour or so.
Customer: replied 1 year ago.
Mike,i agree that some coolant in the cylinder can cause rough running at start up.once that coolant burns off it should smooth out.initially this car had a driver signal missing on pin 9 from from pcm to cylinder 3,lab scope was flat line,other 3 were fine with correct wave form.i replaced pcm with a used unit re programed,car start and runs,with a miss on 3in gear,no problem at road speed,doing coolant leak test will let you know in the am.i used to live in port jeff area
Expert:  Mike V. replied 1 year ago.
I agree with you on the coolant, so the car is only misfire when in gear?

Related Car Questions