How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Clifton B. Your Own Question
Clifton B.
Clifton B., Auto Service Technician
Category: Car
Satisfied Customers: 3780
Experience:  Master Auto Tech
Type Your Car Question Here...
Clifton B. is online now
A new question is answered every 9 seconds

I have codes,p0036,-p0060,-p0141,-p0161,,what would cause a fault on all 4 02 sensors,truc

This answer was rated:

I have codes,p0036,-p0060,-p0141,-p0161,,what would cause a fault on all 4 02 sensors,truck has 50000 miles, ihad driven down bush road,with grass and a few small branches,wires on all sensors look okay,
hi what make and model is your truck ?
Customer: replied 2 years ago.

2011 gmc,sle,extended cab,4x4,5.3 engine,6 speed tranny

Customer: replied 2 years ago.

2011 gmc sle 5.3 litre,4x4

the most likely cause is a blow fuse or a broken wire you should start by checking all the fuses in the car let me know what you fine

Customer: replied 2 years ago.

found blown 10 amp o2 sensor fuse,what would cause blon fuse

it could be that one of the sensors are shorted causing the fuse to blow , replace the fuse if it blow again unplug all the sensors replace the fuse again then plug them in one by one if you plug one in and the fuse blow that is the bad one replace it .
Clifton B. and 4 other Car Specialists are ready to help you
let me know if you have more questions
please remember to rate my answer as this is the only way I will get credit