How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Gary Your Own Question
Gary, Technician
Category: Car
Satisfied Customers: 15564
Experience:  GM master tech for 15 years/ASE master tech for 20 years
Type Your Car Question Here...
Gary is online now
A new question is answered every 9 seconds

Isuzu Rodeo: I have a 1994 Isuzu Rodeo 2WD, Automatic Trans,

This answer was rated:

I have a 1994 Isuzu Rodeo 2WD, Automatic Trans, 3.2L V6. the engine runs rough and I am getting 2 different diagnoses from 2 different mechanics. 1 is convinced it has a miss but there is no evidence of a miss in the ignition or fuel system and the other mechanic is convinced it is a part of the drive line out of balance, (i.e. the flywheel has lost a balance weight. short of have the transmission separated from the engine how can I narrow this down?



Welcome! My name is XXXXX XXXXX I will do my best to assist you with this problem.

will it run rough just at idle or when driving at speed ?

Customer: replied 2 years ago.

when at speed it runs and accelerates just fine but you can feel a vibration when when you decelerate.

will it do this at idle or in park revving it up a bit ?


Customer: replied 2 years ago.

it will at idle and in park revving it up.


ok if it is doing this in park when you rev it up its the engine or possibly the torque convertor

what you can do is remove the torque convertor bolts so the convertor is disconnected from the flex plate if it still does this its the engine running poor causing this or the engine is out of balance from the flex plate or possibly the front crank shaft harmonic balancer

Gary and other Car Specialists are ready to help you
Customer: replied 2 years ago.

Just fyi. I just discovered a leaky injector on the front passenger cylinder ,

ok so it was the engine skipping causing this ?