How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Technician
Category: Car
Satisfied Customers: 24703
Experience:  17 years automotive training and experience.
14928985
Type Your Car Question Here...
Pete is online now
A new question is answered every 9 seconds

Infiniti I30:p1464 , p10500

This answer was rated:

 Hi I've got a 2000 infiniti i30 touring with 149k miles i had 3 codes , so i took the car to the dealer to find out what's the problem then fix it on my own i had P1320 , P1464 , and P0500 so the dealer told me that i've got to replace " coils , spark plugs , maf sensor , speedo head only , and fuel sending unit " so first thing i did i replaced coils and spark plugs and maf sensor , and the car got better and the first code was gone which was P1320 then i bought OEM NISSAN " fuel sending unit " and replaced it and the code P1464 still there , and also bought a cluster with only 28k miles on it and replaced the speedo head and the p0500 is still there , after the speedo head was replaced the car had more,response to the throttle but not long after the code comes back and the response to the throttle is lacking power. I am unsure of what the next steps should be. If you can help please , i need the car to pass smog.

Hi,

I'm a moderator for this topic. I've been working hard to find a Professional to assist you right away, but sometimes finding the right professional can take a little longer than expected.

I wonder whether you're ok with continuing to wait for an answer. If you are, please let me know and I will continue my search. If not, feel free to let me know and I will cancel this question for you.

Thank you!
Customer: replied 3 years ago.

Yes I am ok with waiting


Thanks

Thank you for your continued patience. We will continue the search for a professional for you.
Customer: replied 3 years ago.

thanks man


let me know when you have one

My name is XXXXX XXXXX I am a professional here at Just Answer/Pearl. I noticed that your question was not getting a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.

Are the only codes you have or are showing up now is the P1464 and the P0500 codes?

Was the vehicle speed sensor ever replaced?

Let me know so we can continue,thanks Pete.
Customer: replied 3 years ago.

Yeah those are the only codes I have right now , and the vehicle speed sensor hasn't been replaced before , the dealer told me to replace the Speedo head "only the part that shows speed gauge with mileage on bottom on the cluster not the whole thing , and I did but no luck

O.k.,P0500 will set when a fault is detected with the vehicle speed sensor itself or possibly wiring to the sensor.In most cases it usually ends up being a faulty vehicle speed sensor.This code setting can cause the vehicle to go into a fail safe limp mode and cause the power issue or running issue you have described above.I suspect you have a failing vehicle speed sensor.

Code P1464 will set when a fault is detected with the fuel level sensor or circuit.The level sensor is the component you have already replaced.

With what you have described with both of these faults this may be wiring leading from under the vehicle up to the computer at fault.I would start with inspecting wiring leading from the fuel level sender and trace it to see if you locate any damaged or corroded wiring.If any is found it would need repaired to correct this here.

Thanks Pete
Customer: replied 3 years ago.

Ok , so where in the car should I start with this problem

I would start at the fuel tank where you replaced the level sensor and trace the wiring leading off of this level sensor to where it runs to see if you find any wiring damaged or at fault causing both of these codes and this issue here.

Since the wiring for both the vehicle speed sensor and fuel level sensor are under the vehicle most likely there is a point in the wiring under the vehicle or leading up to the computer at fault and needs repaired.

Thanks Pete
Customer: replied 3 years ago.

Ok I'll try to do that


But you think it's just a tracing wires process I have to perform , right ?

It is possible this is a wiring issue only for the fuel level sensor and you may also have a faulty vehicle speed sensor.But with both of these components most likely in the same wiring loom leading from under the vehicle to the computer most likely this is just wiring at fault and tracing wires is where I would start to see if the fault is located.

Thanks Pete
Customer: replied 3 years ago.

hi pete


where is the vehicle speed sensor located ?


i know there are revolution sensor and a vss , is it the one you see from the driver's side fender or the one on the transmission

I apologize for the delay in response.

According to my info this vehicle speed sensor is located on the transmission itself and appears to be on the drivers side or bottom of the transmission.Unfortunately I was unable to locate a good picture on this but did locate one here below and hope it helps.

graphic

Thanks Pete
Pete, Technician
Category: Car
Satisfied Customers: 24703
Experience: 17 years automotive training and experience.
Pete and 2 other Car Specialists are ready to help you
Customer: replied 3 years ago.

Ok thanks Pete


Picture is not very clear but if you have another one let me know , thanks though

I apologize for the delay.Unfortunately that is the only picture I was able to locate for this here.

Thanks Pete

Related Car Questions