How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Technician
Category: Car
Satisfied Customers: 27563
Experience:  17 years automotive training and experience.
14928985
Type Your Car Question Here...
Pete is online now
A new question is answered every 9 seconds

Toyota landcruiser: Hi, My 100 series 4.5l petrol landcruiser

This answer was rated:

Hi, My 100 series 4.5l petrol landcruiser has developed a surge/ hesitation at low rpm and when backing off acceleration, never under full acceleration. I have replaced spark plugs, fuel filter and put injector clean through the fuel system. I have also cleaned all electrical connections to coil packs and cleaned throttle body of carbon build up. Do you have any other theory on this please.
My name is XXXXX XXXXX I am a professional here at Just Answer/Pearl. I noticed that your question was not getting a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.

The first thing I would check for is to see if the engine has a vacuum leak present.In some cases the engine can lean out and this type of fault can occur from a vacuum leak.If no visible leak is located you might try and have the intake smoke tested to see if any smoke leaks out where it shouldn't as this is an indication of a leak that needs corrected.

If this is checked or has already been checked and found to be o.k. let me know and we can continue.

Thanks Pete
Pete and other Car Specialists are ready to help you
Hi,

I am following up with you to see if you still needed help with your question you had asked.If my help didn't satisfy your question please let me know so we can continue.

Thanks Pete
Customer: replied 3 years ago.

Hi Pete, I had a small vacuum leak. I repaired this and the problem is still there.


 


Thanks

Have fault codes been read out with a scan tool at all to see what or if any fault codes have set?

Related Car Questions