How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Tim's Auto Repair Your Own Question
Tim's Auto Repair
Tim's Auto Repair, Mechanic
Category: Car
Satisfied Customers: 15478
Experience:  Have owned a repair shop for 25 yrs.
14541291
Type Your Car Question Here...
Tim's Auto Repair is online now
A new question is answered every 9 seconds

Isuzu Rodeo: engine had a surge for months. she stopped at

This answer was rated:

engine had a surge for months. she stopped at a station for fuel and about 15 miles later car lost power and would not pull itself then stalled and would not start. check engine light came on stating #3 plug missfired and knock sensor detected a knock. after clearing DTC nothing else has come up. when car cooled down would start but not pull self. fuel filter clogged so replaced. started and sounded fine at idle but will hesitate and die and if allowed to warm up will die and not start.

tims auto repair :

hi

tims auto repair :

do you get any trouble codes now?

tims auto repair :

do you have the 3.2 or 3.5 engine?

JACUSTOMER-1cklm2ih- :

3.2

JACUSTOMER-1cklm2ih- :

no further codes have appeared

tims auto repair :

does it run well cold?

JACUSTOMER-1cklm2ih- :

ok but a little rough. better than before this latest incident.

tims auto repair :

ok

tims auto repair :

does the engine seem to miss when cold?

JACUSTOMER-1cklm2ih- :

no

tims auto repair :

how many miles is on it?

JACUSTOMER-1cklm2ih- :

125000

tims auto repair :

explain to me how it runs when cold?

JACUSTOMER-1cklm2ih- :

did a valve job last year and replaced the timing belt etc then.

JACUSTOMER-1cklm2ih- :

just runs a little rough. not totally smooth

tims auto repair :

ok

tims auto repair :

now,,when hot?

JACUSTOMER-1cklm2ih- :

if you give it gas it has no power. when warm it is much worsd will die and be hard to start

tims auto repair :

but,,it will start when hot?

JACUSTOMER-1cklm2ih- :

if fully warmed up, no. it will refise to start.

tims auto repair :

ok

tims auto repair :

sense you dont get a code now

tims auto repair :

and from the way you explain

tims auto repair :

i think we need to look at a couple of things here

tims auto repair :

1-,,if it hasnt had a tune up in a while,,please do so,,new plugs and plug boots

tims auto repair :

2-\

tims auto repair :

remove the air intake duct and clean the throttle body and the maf sensor with carb cleaner

tims auto repair :

 
















15_sz02rdall_esm_201-048.jpg
Full Size Image

48. Left Front of Engine (3.2L Engine)



tims auto repair :

3-test the fuel pressure,,,,it must have no less than 42psi at all times

JACUSTOMER-1cklm2ih- :

ok, will do that now. SHouldn't take that long.

tims auto repair :

4-..sense it doesnt want to start when hot

tims auto repair :

you could have a bad crank sensor

tims auto repair :

these can go bad and be heat sensitive ,,and not give a code

tims auto repair :

this may be why it doesnt start when hot

tims auto repair :

also,,dont forget the fuel pressure,,sometimes a bad fuel pump will get weak when it gets hot

JACUSTOMER-1cklm2ih- :

where in the sensor located?

tims auto repair :

 
















26_sz02rdall_esm_201-056.jpg
Full Size Image

56. Bottom Right Side of Engine










52_sz04rodeo_ewd_201-056.jpg
Full Size Image

56.Bottom Right Side Of Engine



tims auto repair :

i hope this has helped

tims auto repair :




JACUSTOMER-1cklm2ih- :

how do I come back and ask more questions if needed?

tims auto repair :

just sign in and reply back to this question

tims auto repair :

i will answer when i get back on line

JACUSTOMER-1cklm2ih- :

ok, thanks

tims auto repair :

you are very welcome

tims auto repair :




tims auto repair :

thanks for using justanswer

Tim's Auto Repair and 11 other Car Specialists are ready to help you
Customer: replied 3 years ago.


Turns out it's a 2.2L engine. Will that make any changes to the troubleshooting?

not really,,same thoughts,,though the crank sensor is in a different place
thanks
Customer: replied 3 years ago.


Still haven't gotten the car running. did what was suggested but nothing has worked. Good responses and quick just didn't get the engine running. Turns over, runs for a minute, sounds out of time, timimg belt checks out right but replaced anyway. Still no codes showing.


Won't blame this forum, just didn't get to to the problem.