How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask hilltop4527 Your Own Question
hilltop4527
hilltop4527, Auto Service Technician
Category: Car
Satisfied Customers: 91
Experience:  Independent repair shop owner/operator experience with many makes and models both foreign and domestic.
70175367
Type Your Car Question Here...
hilltop4527 is online now
A new question is answered every 9 seconds

I had a new performance exhaust system installed, when I picked

This answer was rated:

I had a new performance exhaust system installed, when I picked up my car all the exterior lights are acting up. the low beam lights do not work at all, the high beam lights are on instead of the low beams with reduced wattage, when you turn on the high beam lights only the left light comes on at full wattage and the right one goes out. with the lights on the front turn signals do not work but the backs do, with the lights off the turn signals work fine.
Hi I see you are having trouble. I will try to help. I would suspect that the exhaust shop had to do some welding on your exhaust system and they forgot to remove the ground terminal from your battery to prevent high current flow through your vehicles electrical system. If your lucky it only blew some fuses, but it may have burnt wires or even fried your computer. I would put this back in the exhaust shops lap. But If you want to try to diagnose your self first I would remove the negative terminal from the battery for 10 minutes. This will reset all computers. Then put the terminal back on and see if everything is working right. If not I would then look for blown fuses. Then after that toasted wires. Thank you for using just answer.
hilltop4527 and 9 other Car Specialists are ready to help you
Customer: replied 3 years ago.

Well this morning as I was pulling out of my driveway I heard a click and all the lights began working properly. I did notify the shop of my problem and they had me scheduled to bring it in tomorrow. I stopped in today and told them what happened and they seem to think its a switch of some sort. As long as they are working I am ok, but if it happens again they said to bring it back to them.


Thanks for your advice.