How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Matt Your Own Question
Matt
Matt, Engineer
Category: Car
Satisfied Customers: 20803
Experience:  Honors degree in Mechanical Engineering, worked 8 years as a Formula 1 engine engineer.
12772297
Type Your Car Question Here...
Matt is online now
A new question is answered every 9 seconds

SSPS LIGHT STAYS ON AND CAR ACTS LIKE IT IS DE- ACCELERATING

This answer was rated:

SSPS LIGHT STAYS ON AND CAR ACTS LIKE IT IS DE- ACCELERATING WHILE DRIVING. GAS PEDAL DOES NOT GIVE IT GAS
Hello

On any car if you get a check engine light or other fault light this typically means one or more of the sensors has failed or has a faulty connection.

The ECU senses this and may put the car into 'limp home' mode which typically limits the revs and the amount of power available. Usually the car is safe to drive for a short distance as the mode is intended is intended to get you home without incurring any engine damage

The quickest route to repair is to have the car plugged into a diagnostic machine which will read off the fault code stored in the ECU (providing the light is still on at this point) and indicate which sensor has failed or whether the fault is more serious.

You can do a very rough and ready check yourself by unplugging sensors one at a time and seeing if any of them change the driving condition which would indicate the most recently unplugged sensor is the faulty one. This method is not foolproof though and reading a fault code off is the better method.

from your description this could be an issue with the throttle body motor or the mass airflow sensor or a lack of fuel pressure but rather than give you a try this and try that answer I'd really suggest getting the fault codes off 1st and get back to me on this post
Matt and 7 other Car Specialists are ready to help you
Customer: replied 3 years ago.

TOOK CAR TO ADVANCE AUTO FOR CODE DIAGNOSIS SHOWED NO CODE SHOWING EVERYTHING SHOWED OK, SSPS LIGHT STILL ON AND CAR DOING SAME THING.

Hello Don

the SSPS is for 'speed sensitive power steering' but a fault with this shouldn't effect the engine power unless there's some short with the system thats effecting the ECU

If the steering feels OK then I'd suggest that this could be an airleak after the airflow meter, any air dragged in here isn't 'seen' by the ECU and so not compensated for and can lean the engine out and can also allow the engine to rev up when not desired causing rough running.
As its a mechanical fault it tends not to turn on the fault light and you can sometimes hear a 'hissing' noise with the engine running.

Check the hose clips for tightness and inspect the trunking for any cracks or splits and also all the vacuum system, the small bore pipes and fittings for cracks and missing parts.

The best way to locate a leak is to have the engine running and warm and then spray lighter gas /propane around each joint in turn. If the engine rev's up you've found your leak.
Now you might think that spraying lighter gas around a hot engine isn’t wise, however the flash /ignition point of gas is about 400°C so you need a naked flame or spark to set it off and I’ve used this method for many years without incident.
Work your way through each possible joint one at a time and you should find it. I use a slightly flattened piece of brake pipe and some rubber hose from the can of lighter gas to provide a spraying 'wand' and allow a direct blast of gas into each area, especially those difficult to reach with large implements.

It’s also worth getting the fuel pressure checked as if this is low due to a blocked filter or faulty regulator or even a poorly pump will all result in insufficient fuel being delivered to the engine

Might also be worth cleaning out the throttle body as these get clogged up with carbon and some brake cleaner washed through helps free things off.

Might also be worth checking the wiring and connector to the airflow meter for any signs of corrosion or damage. you can do a quick fault find if you unplug the meter and run the engine without it.
if the engine condition is the same then chances are the meter or the connection to it is faulty

Air leaks are very temperature dependent as gaps can open or close up as things expand with heat, so the weather and engine temperature can effect them.

This leads them to be quite intermittent in the case of mild leaks

its also worth cleaning the airflow meter by removing it from the car and spraying the exposed sensor wires inside the tube with a brake or switch cleaner - ensure that the cleaner is one of the old fashioned, non Eco type that does not leave a residue

On no account touch the sensor wires with anything physical as they are extremely fragile
Customer: replied 3 years ago.

FOUND OUT THAT OUR FORENZA HAS A POSSIBLE 4 SSPS SENSORS AND ONE OF THEM IS ON THE TRANSMISSION AND COULD BE CAUSING THE PROBLEM I ASKED YOU ABOUT. I WOULD OF LIKE TO HAVE HAD A BETTER ANSWER, OR AT LEAST A MORE NARROWED DOWN ANSWER.

Hello Don

You can measure the resistance of the speed sensor in the transmission as it should be 200-300 ohms over the outer pins

if its outside this then replace the sensor