How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask sprinkles08 Your Own Question
sprinkles08, ASE Certified Technician
Category: Car
Satisfied Customers: 21420
Experience:  ASE Master and Advanced level certified. Factory trained with 15 years dealership experience
Type Your Car Question Here...
sprinkles08 is online now
A new question is answered every 9 seconds

Mitsubishi Express: I have 1996 Mitsubishi express 4x4 with

This answer was rated:

I have 1996 Mitsubishi express 4x4 with a 2.4 eci eng , it stopped the other day and as far as I can tell the injection computer has stopped working first off we're is the eci comp situated and how do I check to see if it is faulty Rgds Allan

Hello and welcome to JustAnswer!


If it runs when supplying fuel in the intake then you either have no injector pulse or low/no fuel pressure. Since you do have spark then the most likely cause would be fuel pressure.


I see that you say the fuel pump seems to be working. The first thing I would recommend is checking actual fuel pressure with a gauge, or you could use a test light or noid light to see if there is injector pulse. If there is pulse then you know for sure that you have a fuel delivery issue.


If there is fuel pressure but it's low then the pump is bad or it is being supplied a poor power or ground.


If you are missing injector pulse then it could be an ECM, wiring, cam or crank sensor issue. It's unlikely to be a cam or crank sensor issue since you have spark. If you do find injector pulse is missing then the first step from there will be to check for fault codes using a scan tool or code reader.

sprinkles08 and 6 other Car Specialists are ready to help you
Customer: replied 3 years ago.

have tried what you suggested but with no luck, have checked the injector power feed, I do not know if the test light is supposed to pulse or not but both wires to the injectors have power , put in another fuel pump with no luck so how do I check if the ecu or whatever you call it is working properly ? and were is it located ? rgds Allan

What did you find for fuel pressure?

Do you have power at the injectors while cranking?

Do you have injector pulse?

Have you checked for fault codes?

Related Car Questions