How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Technician
Category: Car
Satisfied Customers: 25350
Experience:  17 years automotive training and experience.
14928985
Type Your Car Question Here...
Pete is online now
A new question is answered every 9 seconds

Masarati Gran Tourismo: 2008 Masarati Gran TourismoReplaced

This answer was rated:

2008 Masarati Gran Tourismo Replaced A/C condenser and Compressor. Pully was frozen on compressor. Charged compressor with R134a. Turned. A/c on and not working. Blower comes on but does not blow cold. Ideas ?? All parts replaced were ffactory any answer yet ??

My name is XXXXX XXXXX I am a professional here at Just Answer. I noticed that your question was not getting a response and thought I would see if you still need help with this.

I would inspect the heater/ac fuses to see if one has blown.If the old compressor froze up or the clutch froze up on the compressor this may cause a fuse to short out and blow causing the no compressor engagement you have now.

If this is o.k. make sure you have put in the correct charge/amount of freon in the ac system.If it is under filled and in some cases over filled with freon the compressor may not engage due to the pressure sensors in the ac system indicating a problem.

Both of these here will cause this type of fault and need checked into further to locate and correct the fault.This may be an issue with the control on the dash as well not engaging the ac but is usually rare to fail when a compressor fails.

Thanks Pete
Customer: replied 3 years ago.

Pete


Thank you for taking time to reply. I was remiss in not stating that we did check the fuses and relays and all checked out ok. The customer said that he was driving in Arizona when the A/C stopped working, it made grinding noise and he smelled something burning. We inspected the compressor and it had the pulley very loose and when we spun it, it did indeed have a grinding noise , I guess with that said, I will have to trace the wiring for signs of burnt wiring, we did not observe any signs when we were replacing the compressor All fuses and relays check out ok.

O.k.,with all fuses and relays being o.k. I don't think the amperage draw from this that had occurred would have damaged the control unit as it would usually blow a fuse first but it is possible the signal to turn on the compressor if not fused it can lead to the control unit failure.Unfortunately my diagram info on this model is very limited so I cannot see if it is a fused circuit or not.

I would also inspect to see if the wiring is burned or damaged at any point as well.

Thanks Pete
Pete and 9 other Car Specialists are ready to help you
Hi,

I am following up with you to see if you still needed help with your question you had asked.If my help didn't satisfy your question please let me know so we can continue.

Thanks Pete