How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask ClayA Your Own Question
ClayA
ClayA, ASE Certified Technician
Category: Car
Satisfied Customers: 116
Experience:  Ten years experience, ASE Master and Advanced Level Specialist certifications. 2006 Winner National Ford/AAA Student Auto Skills
74704726
Type Your Car Question Here...
ClayA is online now
A new question is answered every 9 seconds

isuzu rodeo: I just bought a 2003 rodeo the other day, and

This answer was rated:

I just bought a 2003 rodeo the other day, and it had a bad battery. I tried to jump start the rodeo and that would not work. I went and bought a new battery, installed it and the engine will not crank or even try to turn over as previously stated. The lights on the dash are working properly. However, neither the power windows nor the sunroof will work. I have checked the fuses in the cab and in the engine compartment and all are good. I have 3 sets of keys and have used each of them to try and start the car- the only thing I have heard is a very faint click sound once every so often when I turn the ignition over.

Make sure that the 100amp main fuse is not blown. It is the common power source for all the issues you listed.

ClayA, ASE Certified Technician
Category: Car
Satisfied Customers: 116
Experience: Ten years experience, ASE Master and Advanced Level Specialist certifications. 2006 Winner National Ford/AAA Student Auto Skills
ClayA and 8 other Car Specialists are ready to help you
Customer: replied 3 years ago.


That was it, Thanks for the help!

Thank you for posting that the vehicle is fixed.

Please, make sure to click the Accept button or I don't get credit for the question.

Thank you for your business and have a nice day.
Customer: replied 3 years ago.

Thanks for your help Clay, but now there is another problem: the rodeo ran fine after takingXXXXXyesterday. This morning the check engine and ABS lights were on, the turn signals would not work, and the car was severely underpowered when stepping on the gas. I tried to replace the turn signal fuse (it was blown) and when I put in a replacement fuse that was blown too. Any ideas?

Do you have the code number for the check engine light?
To know why the car was underpowered I will need the code number.

For the blown turn signal fuse you will have to diagnose the short. The turn signal power goes through the hazard switch, flasher unit, turn signal switch, then to the lights in that order. Start by unplugging the hazard switch and see if the fuse blows. Then the flasher unit and so on till you get to the turn signal bulbs. Instead of popping alot of fuses you can use the method in the link below to test for a short circuit.

Except in the method below you start at the end of your circuit and work towards the fuse.

Link here
Customer: replied 3 years ago.


The engine code is P1601 and to add to the list the RPM gauge is out also

Customer: replied 3 years ago.
Relist: Other.
clay may be off today and I am under time constraints.
Hi I’m Tom and I’m here to assist you with your issue today. Before I get you a fully researched answer, I have to ask you a couple preliminary questions.HAve you checked to see if any other fuses are blown also has the alternator been checked it very well can be shorted out .As for the code thats for a shorted ECU are there any other codes stored ?
Customer: replied 3 years ago.

The fuse for the turn signals has blown each time it has been replaced. No other fuses are blown since I checked last night. the alternator has not been checked out and there are no other error codes showing

OK if you disconnect the alternator does the fuse still blow ?
Customer: replied 3 years ago.

I don't have the tools necessary to disconnect the alternator. I will have to stop by a shop tomorrow to get that checked

I will not be online much the next few days. So, I am going to opt out and let Cardoctor74 take over.

Thank you,
ClayA
Please let me know when you are ready to continue .
Customer: replied 3 years ago.

The alternator has tested fine and fuses do not blow when it has been disconnected. I replaced the ECM fuse also and no changes in the way it is operating

But fuses did not blow when the alternator was disconnect correct ?
Customer: replied 3 years ago.

correct, when the alternator was reconnected the 15 amp turn signal fuse blew again

Ok let me ask you this what are the readings of the alternator under an extreme load radio ,high beams,a/c etc? Also is there a trailer hitch on this vehicle ?
Customer: replied 3 years ago.

There is no trailer hitch on it and the mechanic has left for the day and closed shop until tomorrow. he did test it under the conditions you mentioned but did not say anything about the readings other than the alternator tested ok

Ok if the fuses did not blow with the the alternator disconnected there is a dead short somewhere in the system . Are you willing to try to trace it with me?

Related Car Questions